Closed Bug 1341588 Opened 3 years ago Closed 3 years ago

Long tapping in blank in a cell which only has a word and adjacent cells only has a replaced element causes selects the word and replaced elements on Android

Categories

(Core :: Selection, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox54 --- wontfix
firefox55 --- fixed

People

(Reporter: masayuki, Assigned: TYLin)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase)

Attachments

(3 files)

STR:
1. Open https://jsfiddle.net/d_toybox/avk5ga7t/8/
2. Tab the right-bottom frame to focus the frame.
3. Long tap at blank space of right of "aaa" (2nd row and 1st column).

Actual result:
In the 1st table and the 3rd table, selected from start of "aaa" to start of 2nd row's "button1" or "input1".
In the 2nd table and the 4th table, selected from start of previous row's "button2" or "input2" to start of 2nd row's "button2" or "input2".

Expected result:
Only "aaa" should be selected (like you do it in 5th or 6th table).

Similar to bug 1338445, but the fix won't have fixed this bug.
Again, this is another bug caused by the phone number selection extension on Fennec.

The key to fix this bug is that we should extend the selection only if the current selection is already matching the phone number regular expression.
Assignee: nobody → tlin
Status: NEW → ASSIGNED
Comment on attachment 8844380 [details]
Bug 1341588 Part 1 - Add spaces to the static comments for aesthetic reason.

https://reviewboard.mozilla.org/r/117874/#review119844
Attachment #8844380 - Flags: review?(mtseng) → review+
Comment on attachment 8844381 [details]
Bug 1341588 Part 2 - Add StringifiedSelection() to simplify code.

https://reviewboard.mozilla.org/r/117876/#review119846
Attachment #8844381 - Flags: review?(mtseng) → review+
Comment on attachment 8844382 [details]
Bug 1341588 Part 3 - Extend phone number selection only if it is already a phone number.

https://reviewboard.mozilla.org/r/117878/#review119850
Attachment #8844382 - Flags: review?(mtseng) → review+
Pushed by tlin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ed8a0f35be9
Part 1 - Add spaces to the static comments for aesthetic reason. r=mtseng
https://hg.mozilla.org/integration/autoland/rev/fd3d0dcb5add
Part 2 - Add StringifiedSelection() to simplify code. r=mtseng
https://hg.mozilla.org/integration/autoland/rev/d02a07d3ca63
Part 3 - Extend phone number selection only if it is already a phone number. r=mtseng
https://hg.mozilla.org/mozilla-central/rev/7ed8a0f35be9
https://hg.mozilla.org/mozilla-central/rev/fd3d0dcb5add
https://hg.mozilla.org/mozilla-central/rev/d02a07d3ca63
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
-> v.

Thank you very much!
Status: RESOLVED → VERIFIED
Depends on: 1370762
You need to log in before you can comment on or make changes to this bug.