pulsenotify throws exception when client doesn't exist

RESOLVED DUPLICATE of bug 1339377

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1339377
a year ago
a year ago

People

(Reporter: coop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Here's a log extract from papertrail:

Feb 16 00:42:34 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,166 - pulsenotify.plugins - INFO - log_collect plugin initialized 
Feb 16 00:42:34 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,177 - pulsenotify.plugins.irc - INFO - irc plugin initialized. 
Feb 16 00:42:34 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,453 - pulsenotify.plugins - INFO - ses plugin initialized 
Feb 16 00:42:34 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,461 - pulsenotify.plugins.ses - INFO - ses plugin initialized. 
Feb 16 00:42:34 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,463 - pulsenotify.consumer - INFO - Consumer initialized. 
Feb 16 00:42:35 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,915 - asyncio - ERROR - Unhandled exception in event loop 
Feb 16 00:42:35 heroku-release-notifications app/worker.1: Traceback (most recent call last): 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:   File "uvloop/handles/stream.pyx", line 786, in uvloop.loop.__uv_stream_on_read_impl (uvloop/loop.c:63166) 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:   File "uvloop/handles/stream.pyx", line 560, in uvloop.loop.UVStream._on_read (uvloop/loop.c:60666) 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:   File "/app/.heroku/python/lib/python3.5/asyncio/sslproto.py", line 505, in data_received 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:     self._app_protocol.data_received(chunk) 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:   File "/app/.heroku/python/lib/python3.5/site-packages/bottom/protocol.py", line 31, in data_received 
Feb 16 00:42:35 heroku-release-notifications app/worker.1:     message = line.decode(self.client.encoding, "ignore").strip() 
Feb 16 00:42:35 heroku-release-notifications app/worker.1: AttributeError: 'NoneType' object has no attribute 'encoding' 
Feb 16 00:42:35 heroku-release-notifications app/worker.1: 2017-02-16 08:42:34,937 - aioamqp.protocol - INFO - Recv open ok 

We're hitting this exception a couple of times a day. Non-fatal, but it would be good to get rid of the noise.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1339377
You need to log in before you can comment on or make changes to this bug.