Problems launching a browser windows while quicklaunch is loading

VERIFIED DUPLICATE of bug 130915

Status

VERIFIED DUPLICATE of bug 130915
17 years ago
6 years ago

People

(Reporter: cwhitt, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Reproducibility: Sometimes

Steps to reproduce:
1. log in to win2000 (with quicklaunch enabled)
2. launch mozilla manually (from the windows quicklaunch bar or desktop icon)
before the system tray applications have loaded.
3. Occasionally it is impossible to open a browser window.

I have a few wierd problems with loading a browser window as soon as I log in on
Win2k.  The problems are difficult to reproduce consistently, but occur when I
launch mozilla manually before tray icons and quicklaunch have all loaded.

On older builds I saw an occasional crash.  With 2002032709, I now see a hang.  

On my first attempt, quicklaunch loaded successfully, and Exit Mozilla was
disabled as if a browser window was open.  However, I could not open a browser
window either from the quicklaunch menu, by clicking on the mozilla desktop
shortcut, or by opening mailnews and then typing CTRL+1.  Windows task manager
only showed one mozilla process, which was not consuming CPU time.

On my second attempt, I saw the splash screen load, but it stayed on screen
indefinitely.  The quicklaunch tray icon did not load, and I killed the mozilla
process after about 30 seconds or a minute.

I will attempt to reproduce this again, and report back with more information if
possible.  I see any dupes in the open Quicklaunch bugs, but I'm leaving UNCO
for now.

Comment 1

17 years ago
This sounds like a dupe of my "unconfirmed" bug 130915 (c.3-14-2002 on WinNT).

Can someone with authority update both bugs?
(Reporter)

Comment 2

17 years ago
I'm not certain this is exactly the same as bug 130915, so I'm going to leave
them both as is until somebody else can add some insight to what's happening here...

I did add a note to 130915 mentioning this bug, though.

There definitely does seem to be some kind of race condition related to loading
moz before quicklaunch is finished loading.  One of these needs to be confirmed
eventually.  I'll see if I can get somebody else to look at this.
(Reporter)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 130915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
*** Bug 132555 has been marked as a duplicate of this bug. ***
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.