404 Not Found for autoconf213.rb when running mach bootstrap on OSX

RESOLVED DUPLICATE of bug 1329398

Status

RESOLVED DUPLICATE of bug 1329398
2 years ago
6 months ago

People

(Reporter: sfoster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
With a new/up-to-date homebrew and moz-central checkout, when I run ./mach bootstrap, the attempt to download autoconf213.rb from the Homebrew github repo fails. It looks like this file was moved to another repo earlier this year, and it is now located at https://github.com/Homebrew/homebrew-core/blob/master/Formula/autoconf@2.13.rb

Full error message: 

curl: (22) The requested URL returned error: 404 Not Found
Error: Failure while executing: /usr/bin/curl --remote-time --location --user-agent Homebrew/1.1.10\ (Macintosh;\ Intel\ macOS\ 10.12.3)\ curl/7.51.0 --progress-bar --fail https://raw.github.com/Homebrew/homebrew-versions/master/autoconf213.rb -o /Users/sfoster/Library/Caches/Homebrew/Formula/autoconf213.rb
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '[u'/usr/local/bin/brew', u'install', u'https://raw.github.com/Homebrew/homebrew-versions/master/autoconf213.rb']' returned non-zero exit status 1

  File "/Users/sfoster/moz/firefox/python/mozboot/mozboot/mach_commands.py", line 26, in bootstrap
    bootstrapper.bootstrap()
  File "/Users/sfoster/moz/firefox/python/mozboot/mozboot/bootstrap.py", line 225, in bootstrap
    self.instance.install_system_packages()
  File "/Users/sfoster/moz/firefox/python/mozboot/mozboot/osx.py", line 188, in install_system_packages
    getattr(self, 'ensure_%s_system_packages' % self.package_manager)()
  File "/Users/sfoster/moz/firefox/python/mozboot/mozboot/osx.py", line 324, in ensure_homebrew_system_packages
    self._ensure_homebrew_packages(packages)
  File "/Users/sfoster/moz/firefox/python/mozboot/mozboot/osx.py", line 302, in _ensure_homebrew_packages
    subprocess.check_call(cmd + ['install', package])
  File "/usr/local/Cellar/python/2.7.13/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 186, in check_call
    raise CalledProcessError(retcode, cmd)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329398

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.