listboxes hosed on Mac - profile manager, mail compose, hosed

VERIFIED FIXED

Status

SeaMonkey
Startup & Profiles
P1
blocker
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: tracy, Assigned: Joe Hewitt (gone))

Tracking

({regression, smoketest})

Trunk
PowerPC
All
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
seen on mac commercial build 2002-03-29-03-trunk

-Install the build
-Run Profile Manager
notice that the field where we' expect to find the list of profiles is 
nonexistant.  

-Click on the create profile button
it brings up it's dialog as expected, but won't allow creation of a new profile. 
A pop up warning comes up say a profile with that name already exist (even 
though I've type in a unique new profile name)
Note: this does actually put a profile in the profiles folder. (which blocks the 
 workaround below because the app wants to use the profile manager)

-back to profile manager
-click on Rename Profile, Delete Profile or Start 
 nothing happens on click of any of these buttons.

Profile manager is completely unusable

The only way to test this build (that I've found), is to nuke the application 
reg in .mozilla profile dir and let the application start with a migrated 
profile.
(Reporter)

Updated

16 years ago
Keywords: regression, smoketest
Priority: -- → P1

Comment 1

16 years ago
->hewitt
Assignee: ben → hewitt

Comment 2

16 years ago
Another workaround is to try opening with a specific profile specified on 
the "command line" (although I'm unclear as to whether or how one does that on 
the Mac).
(Assignee)

Comment 3

16 years ago
*** Bug 134239 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Summary: Can't launch from Profile Manager; missing profiles field (all functionality broken) → listboxes hosed on Mac - profile manager, mail compose, hosed

Comment 4

16 years ago
When trying to open the profile manager dialog I get the following spew:

•••WARNING: CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://global/skin/
listbox.css' failed.  Error code: 16389, file nsCSSLoader.cpp, line 997
WARNING: CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://global/skin/
listbox.css' failed.  Error code: 16389, file nsCSSLoader.cpp, line 997
OS: MacOS X → All

Comment 5

16 years ago
Created attachment 76795 [details] [diff] [review]
Patch.

The listbox css file was not added to the classic jar file. Patch attached.
(Assignee)

Comment 6

16 years ago
Comment on attachment 76795 [details] [diff] [review]
Patch.

sr=hewitt
Attachment #76795 - Flags: superreview+

Comment 7

16 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 134330 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
verified with commercial trunk builds:

mac os9 2002-04-01-03-trunk
mac osx 2002-04-01-03-trunk
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.