Closed Bug 1341932 Opened 3 years ago Closed 3 years ago

waiting page @bugzilla.mozilla.org is not displayed (multipart/x-mixed-replace)

Categories

(Core :: Networking, defect, minor)

54 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: euthanasia_waltz, Assigned: mayhemer)

References

Details

(Keywords: regression, Whiteboard: [necko-active])

Attachments

(1 file)

STR:
1. Search something at bugzilla.mozilla.org

AR:
"Please wait while your bugs are retrieved." page (first part) is not displayed.

ER:
I'm not sure but it should be displayed as usual for now.

mozregression:
 5:08.92 INFO: Last good revision: c16d9ee39ff4720a2d428ddd8b3bdc53183a2ad9
 5:08.92 INFO: First bad revision: 250c680482eb1be0847932509c5ed3f5e121fd26
 5:08.92 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c16d9ee39ff4720a2d428ddd8b3bdc53183a2ad9&tochange=250c680482eb1be0847932509c5ed3f5e121fd26

I wonder if this issue is not related to
 Bug 1276918 - Drop support for navigating to responses whose MIME type is multipart/x-mixed-replace
Apparently bug 1321612.
Blocks: 1321612
Assignee: nobody → honzab.moz
Whiteboard: [necko-active]
I wrote a test for the affected component based on the response of bugzilla search and the patched code behaves actually better than the unpatched.  So I'm confused.  We could also back the large changes introduced in bug 1321612 and use a safer (but less complete) patch for it on branches.

At the moment I have no idea what could be the problem, and we are affected up to beta.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The reported content type is different - application/x-unknown-content-type.  Apparently the preamble has to be ignored instead of interpretation as a header.

The fix here is to correctly ignore the preamble also as we do for the tail.
Status: NEW → ASSIGNED
Attachment #8840492 - Flags: review?(valentin.gosu) → review+
Branches <54 are unaffected since the original patch for bug 1321612 was backed out in favor of the simpler fix.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6a9d8f01342b
Ignore preamble in multimixed converter. r=valentin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6a9d8f01342b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.