Closed Bug 1342000 Opened 4 years ago Closed 4 years ago

Incorrect time for Europe/Moscow

Categories

(bugzilla.mozilla.org :: General, defect, P1)

Production

Tracking

()

RESOLVED FIXED

People

(Reporter: sveta.orlik.code, Assigned: dylan)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170201180315

Steps to reproduce:

1) Set TimeZone as Europe/Moscow
User Preferences >> General Preferences >> "Timezone used to display dates and times" >> Europe/Moscow


Actual results:

Actual Moscow time == 12:00
Bugzilla.mozilla.org time == 13:00
Maybe outdated timezone database on the server after the switch from UTC+4 to UTC+3: https://en.wikipedia.org/wiki/Moscow_Time

Time is correct for Europe/Berlin.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: normal → major
Component: General → Infrastructure
QA Contact: mcote
Is this still an issue? Do we need infra to prioritize this?
It's still an issue.

Your post has the timestamp "2017-04-04 11:04 MSK" while it's 12:25 MSK (UTC+3), so 1h:21min ago.

But with the default bugzilla time zone and the bugmail, it becomes obvious that your post is from 2h:21min ago.
Priority: -- → P1
This is actually because DateTime::TimeZone is outdated. Upgrading that in the vendor tarball is something relating to dev, not infra. I'll take care of this.
Assignee: nobody → dylan
Component: Infrastructure → General
QA Contact: mcote
To github.com:mozilla-bteam/bmo.git
   746bdf1db..1fedd4417  master -> master

This will go out in the next push.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.