No puzzle icon displayed in search results list during installation

RESOLVED WONTFIX

Status

()

P5
normal
RESOLVED WONTFIX
2 years ago
10 months ago

People

(Reporter: vasilica.mihasca, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 unaffected, firefox54 affected)

Details

(Whiteboard: [search], triaged)

Attachments

(1 attachment)

Created attachment 8840409 [details]
2017-02-23_1457.png

[Affected versions]:
Firefox 54.0a1 (2017-02-22)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit


[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create extensions.webextPermissionPrompts and set it to true.
3.Restart the browser.
4.Navigate to Add-ons Manager -> Extensions and search for the following keyword: e10s.
5.Install the second result: “amo e10s”.


[Expected Results]:
A webextension with no icon specified in manifest.json displays the puzzle icon in search results list during the installation process. 


[Actual Results]:
No puzzle icon is displayed in search results list while permissions pop-up is displayed for a webextension with no icon specified in manifest.json. (see attached screenshot)

[Additional notes]:
To be noticed that this issue is also reproducible while installing legacy add-ons but is not so visible because there is no doorhanger that delays the installation process: https://www.screencast.com/t/7f81lqwQdC

Comment 1

2 years ago
Updating the title to match the description in comment 0.
And since this is an existing bug unrelated to permissions, removing the blocker on permissions.
No longer blocks: 1308292
Summary: No puzzle icon displayed in search results list while permissions pop-up is exposed → No puzzle icon displayed in search results list during installation

Updated

2 years ago
Priority: -- → P5
Whiteboard: [search], triaged

Comment 2

10 months ago
This is no longer relevant since bug 1263313 landed.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.