If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

we need better typelib runtime versioning

VERIFIED DUPLICATE of bug 53155

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 53155
18 years ago
9 years ago

People

(Reporter: John Bandhauer, Assigned: Mike McCabe)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
We should designate some high version number (say '2') and make the current
typelib runtime refuse to load typelibs with a version number that high or
higher.

This could save us from ugly crashes later and allows us to change the typelib
format at some future point without being forced to be 100% compatible with old
versions of the product.
(Assignee)

Comment 1

18 years ago
Mass accept as ASSIGNED of xpidl bugs

Updated

18 years ago
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 2

17 years ago
[SPAM] Marking milestone 'future' as part of nsbeta3 triage.
Target Milestone: --- → Future
(Assignee)

Comment 3

17 years ago
Marking as dup of new (and better-commented) bug 53155.

*** This bug has been marked as a duplicate of 53155 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: xpidl → XPCOM
QA Contact: mike+mozilla → xpcom
You need to log in before you can comment on or make changes to this bug.