Port bug 1284897 to IB and TB {Add mechanism to libsandbox_s to track names of files that have been given special sandbox access permissions (PermissionsService)}

RESOLVED FIXED in Thunderbird 54.0

Status

Thunderbird
General
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 54.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.33 KB, patch
Jorg K (GMT+2) (bustage-fix only, NI for urgent reviews)
: review+
Details | Diff | Splinter Review
(Assignee)

Comment 1

a year ago
Created attachment 8840521 [details] [diff] [review]
Bug1342151.patch

Simple port to IB and TB.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8840521 - Flags: review?(aleth)
(Assignee)

Comment 2

a year ago
Comment on attachment 8840521 [details] [diff] [review]
Bug1342151.patch

Jörg, please can you review this patch to get it in ASAP. This causes bug 1342448.
Attachment #8840521 - Flags: review?(aleth) → review?(jorgk)
Comment on attachment 8840521 [details] [diff] [review]
Bug1342151.patch

Sure, thanks.
Attachment #8840521 - Flags: review?(jorgk) → review+
Duplicate of this bug: 1342448
(Assignee)

Comment 5

a year ago
https://hg.mozilla.org/comm-central/rev/89391861d7730b89d41b899e675c5cd4bb844952
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0
FRG and Ratty, you need this, too.
Flags: needinfo?(philip.chee)
Flags: needinfo?(frgrahl)
Yes. SeaMonkey crashes during startup without it. Will put up a bug for SeaMonkey later. Its the same patch. Just the 3 lines are needed. Thanks
Flags: needinfo?(philip.chee)
Flags: needinfo?(frgrahl)
I'm not sure why Richard didn't fix it for you. Sometimes it's a tough call between being nice and interfering with your code. I understand that your main program is a little different to ours, or perhaps not given recent alignment efforts. Feel free to use this bug (changing the summary) and r?jorgk for a fast review ;-)
(Assignee)

Comment 9

a year ago
First I didn't know this will be a bustage fixer, it was meant as only a follow FX without harm. Then it had to be fast and review and approval for check-in is not so fast for SM (yeah, this one was a candidate for a=bustage-fix).
(Assignee)

Comment 10

a year ago
Checked the build. It's working on Windows 10.
Its really no problem. We mailed about it and I didn't think it would cause problems either. Thanks was meant as thanks for the heads up.

FRG
See Also: → bug 1342566
You need to log in before you can comment on or make changes to this bug.