Once set, location permissions cannot be changed

RESOLVED DUPLICATE of bug 1173381

Status

()

RESOLVED DUPLICATE of bug 1173381
2 years ago
2 years ago

People

(Reporter: matt1256, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

Load a website that requests for location, deny location, attempt to revisit site and observe that there is no prompting for location again.


Actual results:

Settings has no option to change permissions.
iOS settings cannot change permissions except for deny/allow the application to get location. Changing this does not affect your previous decision. Once blocked, you remain forever blocked.

Users can uninstall and reinstall the application to get the prompt again.


Expected results:

Although it should not _prompt_ for location again, there should be a convenient way for users to modify their decision.
I believe if we support the WKWebsiteDataStore API we can handle web site storage management which would let us clear per site data.

If this is correct, we can dupe this to bug 1173381. Bug 1173381 also ought to be nominated.
tracking-fxios: --- → ?

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1173381

Updated

2 years ago
tracking-fxios: ? → ---
You need to log in before you can comment on or make changes to this bug.