Closed Bug 1342288 Opened 3 years ago Closed 2 years ago

Fennec should display the entire browser on Chromecast, not just web area

Categories

(Firefox for Android :: Screencasting, defect)

51 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: nevermissing, Assigned: mkaply)

References

Details

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36 NetHelper70

Steps to reproduce:

Step1. I connected chromecast device with galaxy s7, google nexus and LG v20
Step2. Launch firefox browser and browsing any web-site
Step3. Rotate phone to landscape


Actual results:

Mirroring image is abnormal on chromecast device.


Expected results:

Mirroring image should be no problem like other browser.
Attached image Firefox browser
Component: General → Screencasting
Looks like the address bar space is being sent to the remote device. Disabling Full-screen browsing in the general section of the Firefox settings may work around this issue.
Thank you for your kind comment.
I tried this after disabling "Full-screen browsing" in general tap but it's not work well.
I tested with below procedure.

1. Disabled "Full-screen browsing"
2. Kill fire-fox application.
3. Launch the fire-fox app.
==> It's OK.
4. Rotate the phone screen portrait to landscape
==> The symptom is reproduced.


thanks.
kyoohyun.kim
Attached image Chrome browser (obsolete) —
Attachment #8840689 - Attachment description: 20170209_095938.jpg → Firefox browser
For your reference, I attached another image captured with chrome browser.
With chrome browser, mirroring image shown on TV is normal.
With firefox browser, mirroring image shown on TV is leaning to the upper on TV.

Thanks
kyoohyun.kim
Flags: needinfo?(kbrosnan)
By looking at this bug, kyoohyun.kim, are you using the Android system cast screen feature? Thanks
I connected to chromecast device with google chromecast application not cast screen feature(wifi display menu)
Thanks.
Attached image Chrome browsee
Attachment #8846892 - Attachment is obsolete: true
So near as I can tell, somehow we stop being able to cast "native" things to the screen. So URL bar doesn't display, keyboard doesn't display, about:home doesn't display. etc.

The web content still displays.

It's pretty easy to get yourself in this mode - just clicking the tab icon to add a tab causes us to enter this.

I'm at a loss as to why this would happen.
Clearing the NI as there is not something for me to answer in comment 5
Flags: needinfo?(kbrosnan)
So the behavior you're seeing at this point is working as designed.

The current Firefox behavior is to attempt to show only the web content on the screen, not the entire UI.

I'm going to open a new bug to propose that we eliminate this behavior.
Thank you for your comment.
I hope Firefox acts like other browser.
Thanks
Actually, I'm going to morph this bug.

Currently Fennec tries to only show the web content on the screen with a Chromecast. The problem with this approach is that the web view changes a lot. particular when keyboard are displayed and when the device is rotated.

It also means that the appearance on the television is that parts are missing.

We should behave the same way as Chrome and simply show the entire browser.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: firefox screen is displayed abnormally on chromecast device → Fennec should display the entire browser on Chromecast, not just web area
Duplicate of this bug: 1324980
Duplicate of this bug: 1427237
I know I fiddled around with this locally on the advice of snorp. I'm hoping he can point me to the code again.

I vaguely remember you mentioning some place where we set the canvas (or something to that effect) for what we give to the chromecast.

Would you happen to remember? 

Frustratingly, I had a patch and never went anywhere with it.
Flags: needinfo?(snorp)
It's in PresentationMediaPlayerManager.java

We just need to nuke that whole file I think, and then Android will do the default thing and just show our entire app.
Flags: needinfo?(snorp)
Comment on attachment 8956630 [details]
Bug 1342288 - Remove PresentationMediaPlayerManager.

https://reviewboard.mozilla.org/r/225586/#review231458
Attachment #8956630 - Flags: review?(snorp) → review+
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/9e8108c83a68
Remove PresentationMediaPlayerManager. r=snorp
https://hg.mozilla.org/mozilla-central/rev/9e8108c83a68
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Assignee: nobody → mozilla
You need to log in before you can comment on or make changes to this bug.