Closed Bug 1342329 Opened 3 years ago Closed 3 years ago

Regression: Multiple settings linking to Android app settings

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 54
Iteration:
1.16
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: sebastian, Assigned: sebastian)

References

Details

(Keywords: regression, Whiteboard: [MobileAS])

Attachments

(1 file)

This looks like a regression from bug 1312686. Instead of just the "Make default browser" item linking to the app settings a lot of other items now link to it too (e.g. "About Nightly").
Duplicate of this bug: 1343048
Comment on attachment 8840759 [details]
Bug 1342329 - Only link the "default browser" setting to the default apps screen.

https://reviewboard.mozilla.org/r/115192/#review117272
Attachment #8840759 - Flags: review?(ahunt) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s c06eb11d5e8c -d 133ad85684a1: rebasing 378757:c06eb11d5e8c "Bug 1342329 - Only link the "default browser" setting to the default apps screen. r=ahunt" (tip)
merging mobile/android/base/java/org/mozilla/gecko/preferences/GeckoPreferences.java
warning: conflicts while merging mobile/android/base/java/org/mozilla/gecko/preferences/GeckoPreferences.java! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a600cecf698c
Only link the "default browser" setting to the default apps screen. r=ahunt
Iteration: --- → 1.16
Whiteboard: [MobileAS]
https://hg.mozilla.org/mozilla-central/rev/a600cecf698c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
You need to log in before you can comment on or make changes to this bug.