Improve the Wrong Sqlite Version message

RESOLVED FIXED in Firefox 52

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
mozilla54
Points:
---

Firefox Tracking Flags

(firefox52 fixed, firefox-esr52 fixed, firefox53 fixed, firefox54 fixed)

Details

Attachments

(1 attachment)

This message doesn't give to the user any kind of solution, it should be improved.
Comment hidden (mozreview-request)
Andrew, what do you think? Should we go further?
We could ideally even just MOZ_ASSERT and return nullptr here (would that still crash, I suppose not if the consumer does proper error checking?). My doubt is that even if now we fix whatever causes a wrong init, in the future others may do the same.
Unless we figure out a way to tell "xul.dll is not ready" to any code during an update...

Comment 3

2 years ago
mozreview-review
Comment on attachment 8840947 [details]
Bug 1342441 - Improve the Wrong Sqlite Version message.

https://reviewboard.mozilla.org/r/115338/#review116816

This is definitely an improvement.

I don't think returning null is likely to help things since I'd expect the result to be that huge swathes of Firefox end up in a broken/degraded state.  (Somewhat reminiscent of what we've seen in bug 1246615.)  I would expect callers to assume they're in shutdown if null is returned and aggressively stop initializing themselves, etc.  System SQLite users may benefit from leaving the error message around too.
Attachment #8840947 - Flags: review?(bugmail) → review+

Comment 4

2 years ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/cbf582404538
Improve the Wrong Sqlite Version message. r=asuth

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cbf582404538
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Comment on attachment 8840947 [details]
Bug 1342441 - Improve the Wrong Sqlite Version message.

Approval Request Comment
[Feature/Bug causing the regression]: forced crash on startup after a Firefox update. See bug 1341373.
[User impact if declined]: We show a dialog with an unclear string that has no suggested actions for the user
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: It's just changing an hardcoded string
[String changes made/needed]: The string is not localized (this is a rare forced crash due to some still-unresolved issues happening during an update under particular conditions, see bug 1341373)
Attachment #8840947 - Flags: approval-mozilla-esr52?
Attachment #8840947 - Flags: approval-mozilla-beta?
Attachment #8840947 - Flags: approval-mozilla-aurora?
Comment on attachment 8840947 [details]
Bug 1342441 - Improve the Wrong Sqlite Version message.

improve message on sqlite version mismatch, let's take this for 53 (aurora) and 52 (beta/release).
Attachment #8840947 - Flags: approval-mozilla-release+
Attachment #8840947 - Flags: approval-mozilla-esr52?
Attachment #8840947 - Flags: approval-mozilla-beta?
Attachment #8840947 - Flags: approval-mozilla-beta+
Attachment #8840947 - Flags: approval-mozilla-aurora?
Attachment #8840947 - Flags: approval-mozilla-aurora+

Comment 10

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr52/rev/8cc717c3d1c7
status-firefox-esr52: --- → fixed
You need to log in before you can comment on or make changes to this bug.