menulist does not display/draw the first item in the menupopup

RESOLVED DUPLICATE of bug 118038

Status

()

RESOLVED DUPLICATE of bug 118038
17 years ago
16 years ago

People

(Reporter: racham, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using my debug build (pulled around 9pm yesterday), I noticed that menulist 
does not display or the first time properly. This is a regression. It worked as 
exoected before.

Here is the piece of code :

                <menulist id="month">
                  <menupopup>
                    <menuitem label="&monthDefault.label;" value=""/>
                    <menuitem label="01" value="01"/>
                    <menuitem label="02" value="02"/>
                    <menuitem label="03" value="03"/>
                    <menuitem label="04" value="04"/>
                    <menuitem label="05" value="05"/>
                    <menuitem label="06" value="06"/>
                    <menuitem label="07" value="07"/>
                    <menuitem label="08" value="08"/>
                    <menuitem label="09" value="09"/>
                    <menuitem label="10" value="10"/>
                    <menuitem label="11" value="11"/>
                    <menuitem label="12" value="12"/>
                  </menupopup>
                </menulist>

&monthDefault is 'mm' and I don't see it. Same thing with day too.

Comment 1

17 years ago
In a clobber win2k build, pulled 11pm last night, this is working correctly for 
most of the menulists in the preferences dialog. One exception is in the 
'Character Coding' menulist in the 'Navigator->Languages' panel, where the 
first time the popup is shown, the menulist does not scroll down to and 
highlight the default 'Western ISO 8859-1'. It does work correctly on 
subsequent opens of that list (but this may not be a new bug). 

racham, have you tried this in a clobber build (given all the build oddities 
from last night's landings, I don't have any faith in the result shown in a 
depend build). Can you post a complete example of where this does not work?

Comment 2

16 years ago
Fixed by Neil.

*** This bug has been marked as a duplicate of 118038 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.