Change in nsIIOServices extractUrlPart method: No longer returns start and end offsets of parts

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Charles Manske, Assigned: Charles Manske)

Tracking

({regression})

Trunk
mozilla1.0
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish)

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

16 years ago
Composer uses nsIIOServices::extractUrlPart() a lot. Interface change has
busted StripUsernamePassword(). We also need to drop out param objects to all
other calls to this.
(Assignee)

Comment 1

16 years ago
Created attachment 76767 [details] [diff] [review]
Patch v1
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1, regression
Whiteboard: publish
Target Milestone: --- → mozilla1.0

Comment 2

16 years ago
Comment on attachment 76767 [details] [diff] [review]
Patch v1

r=brade
Attachment #76767 - Flags: review+
(Assignee)

Comment 3

16 years ago
Created attachment 76770 [details] [diff] [review]
Patch v2

Look for ":" in case username is same as password
Attachment #76767 - Attachment is obsolete: true
(Assignee)

Comment 4

16 years ago
Created attachment 76775 [details] [diff] [review]
Patch v3

Take my time. Get it right.
Attachment #76770 - Attachment is obsolete: true
(Assignee)

Comment 5

16 years ago
Created attachment 76777 [details] [diff] [review]
Patch v4

Stupid notepad patch. wrong file last time.
Attachment #76775 - Attachment is obsolete: true

Comment 6

16 years ago
Comment on attachment 76777 [details] [diff] [review]
Patch v4

r=akkana
You might consider putting the GetIoService call inside the if (atIndex > 0),
perhaps even inside the try in that if, since the IOService isn't actually used
otherwise.  (You can have the r= either way, no need to submit another patch
for that if you decide to do it.)
Attachment #76777 - Flags: review+

Comment 7

16 years ago
Comment on attachment 76777 [details] [diff] [review]
Patch v4

sr=kin@netscape.com

I like akk's suggestion to move the GetIOService() call into the try, just
before you use it.
Attachment #76777 - Flags: superreview+
(Assignee)

Updated

16 years ago
Blocks: 133823
(Assignee)

Updated

16 years ago
Blocks: 134059
(Assignee)

Updated

16 years ago
No longer blocks: 134059
Whiteboard: publish → publish, FIX IN HAND, need approval

Comment 8

16 years ago
Comment on attachment 76777 [details] [diff] [review]
Patch v4

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #76777 - Flags: approval+
(Assignee)

Updated

16 years ago
Whiteboard: publish, FIX IN HAND, need approval → publish, FIX IN HAND, approved
(Assignee)

Comment 9

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: publish, FIX IN HAND, approved → publish

Comment 10

16 years ago
Charley, can you verify this bug and mar verified-fixed? thanks..
(Assignee)

Comment 11

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.