checkbox for current tree not checked in Repos dropdown

RESOLVED FIXED

Status

Tree Management
Treeherder
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: aryx, Assigned: KWierso)

Tracking

({regression})

Details

Attachments

(1 attachment)

On the top right after one opened the 'Repos' dropdown, the current tree isn't checked anymore (only the cursor: not-allowed; style, it seems). checked="checked" is missing from the input. Should be regression from the last two days.
(Assignee)

Comment 1

a year ago
Bug 1081074 was a recent change to repos.
Depends on: 1081074
Created attachment 8842771 [details] [review]
[treeherder] KWierso:checkrepos > mozilla:master
(Assignee)

Comment 3

a year ago
Comment on attachment 8842771 [details] [review]
[treeherder] KWierso:checkrepos > mozilla:master

This gets the checkboxes working again. 

I noticed, though, that only three repos maximum can be checked now after Bug 1081074 landed, as part of the limit of tracking recently loaded repos. This can also be confusing because you can select three repos other than the currently loaded repo, and the currently loaded repo will become unchecked, but it stays as the currently loaded repo. That's probably something for a different bug to track, though.
Attachment #8842771 - Flags: review?(wlachance)
(Assignee)

Updated

a year ago
Assignee: nobody → wkocher
Comment on attachment 8842771 [details] [review]
[treeherder] KWierso:checkrepos > mozilla:master

I think I'd rather have David Walsh review this, since he's the person who last touched the code in question. Looks ok to me but maybe there's something I'm missing.
Attachment #8842771 - Flags: review?(wlachance) → review?(dwalsh)
Attachment #8842771 - Flags: review?(dwalsh) → review+

Comment 5

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/09c1b58c83f8bea2c00075e0952990fd791ad238
Bug 1342651 - Update the condition for the checkboxes in the repo menu (#2219)
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.