All users were logged out of Bugzilla on October 13th, 2018

Mac back gesture animation leaves unrendered (white) page on all (?) sites

RESOLVED INVALID

Status

()

P2
normal
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: jwbud, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170225020729

Steps to reproduce:

1. Enable the Mac 'back' gesture animation using browser.snapshots.limit
2. Go to a web page
3. Go to another web page
4. Perform gesture for back



Actual results:

https://gfycat.com/OrganicDangerousIndianringneckparakeet

1st time you gesture: white page
2nd time, sometimes the page reloads and works, others you get another white page
(page is loaded since you can see it in web inspector, but not rendered)



Expected results:

The back animation should play and the you should visit the last page you were on.

Updated

2 years ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core

Updated

2 years ago
Priority: -- → P2
Whiteboard: tpi:+
This is not expected to work properly until all dependent bugs in bug 860493 have been addressed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.