Closed Bug 1342676 Opened 3 years ago Closed 3 years ago

Officially disable all plugins but Flash in SeaMonkey 2.50+

Categories

(SeaMonkey :: General, defect)

All
Unspecified
defect
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.50 fixed, seamonkey2.51 fixed)

RESOLVED FIXED
seamonkey2.51
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.50 --- fixed
seamonkey2.51 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1308273 +++

We set plugin.load_flash_only to false in Bug 1308273. This is no longer supported and most plugin code for everything but Flash has already been removed from Gecko 53 and 54. We should remove the pref from SeaMonkey 2.50 and up.
[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: We pretend to support plugins which are no longer supported. 
Testing completed (on m-c, etc.): c-c 
Risk to taking this patch (and alternatives if risky): none 
String changes made by this patch: none
Attachment #8841232 - Flags: review?(iann_bugzilla)
Attachment #8841232 - Flags: approval-comm-aurora?
Comment on attachment 8841232 [details] [diff] [review]
1342676-removepref.patch

r/a=me
Attachment #8841232 - Flags: review?(iann_bugzilla)
Attachment #8841232 - Flags: review+
Attachment #8841232 - Flags: approval-comm-aurora?
Attachment #8841232 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.