Closed Bug 1342852 Opened 3 years ago Closed 3 years ago

subtract overflow when running dom/media/test/test_eme_non_mse_fails.html

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: ayang, Assigned: ayang)

References

Details

Attachments

(1 file)

In test dom/media/test/test_eme_non_mse_fails.html, it crashs due to subtract overflow.

thread '<unnamed>' panicked at 'attempt to subtract with overflow', /Users/alfredo/mozilla/mozilla-unified/media/libstagefright/binding/mp4parse_capi/src/lib.rs:677
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Redirecting call to abort() to mozalloc_abort

Hit MOZ_CRASH() at /Users/alfredo/mozilla/mozilla-unified/memory/mozalloc/mozalloc_abort.cpp:33
Process 98393 stopped
* thread #82: tid = 0xf53c9f, 0x000000010000e2b1 libmozglue.dylib`mozalloc_abort(msg="Redirecting call to abort() to mozalloc_abort\n") + 97 at mozalloc_abort.cpp:33, name = 'MediaPD~oder #1', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
    frame #0: 0x000000010000e2b1 libmozglue.dylib`mozalloc_abort(msg="Redirecting call to abort() to mozalloc_abort\n") + 97 at mozalloc_abort.cpp:33
   30  	#ifdef MOZ_WIDGET_ANDROID
   31  	    abortThroughJava(msg);
   32  	#endif
-> 33  	    MOZ_CRASH();
   34  	}
   35
Assignee: nobody → ayang
Blocks: 1161350
Hooray for overflow checking.
Duplicate of this bug: 1342848
Comment on attachment 8842339 [details]
Bug 1342852 - update rust mp4 parser.

https://reviewboard.mozilla.org/r/116220/#review117986
Attachment #8842339 - Flags: review?(kinetik) → review+
Pushed by ayang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6085498051cc
update rust mp4 parser. r=kinetik
https://hg.mozilla.org/mozilla-central/rev/6085498051cc
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.