"input autocomplete=postal-code" shows insecure password warning below input field

RESOLVED DUPLICATE of bug 917325

Status

()

Firefox
Security
RESOLVED DUPLICATE of bug 917325
11 months ago
11 months ago

People

(Reporter: gerd.neumann, Unassigned)

Tracking

(Blocks: 1 bug, {reproducible})

54 Branch
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8841467 [details]
Insecure_Passwort_on_autocomplete_postal-code__Nightly.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170226030205

Steps to reproduce:

1. Go to http://demo.woothemes.com/storefront/ (it's a demo, but I see this any live websites as well)
2. Add any product to your cart 
3. Proceed to checkout which is http://demo.woothemes.com/storefront/checkout/
4. Click into the "Postcode" input field which is "input autocomplete=postal-code"


Actual results:

Then an insecure password warning appears. See attached screenshot


Expected results:

This warning does not appear for all the other fields, for instance address and town. I think the insecure password should not appear for postal codes. It should appear for login/passwords only.

Updated

11 months ago
Blocks: 1304224
Has STR: --- → yes
Component: Untriaged → Security
Keywords: reproducible
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917325
You need to log in before you can comment on or make changes to this bug.