Intermittent stylo image/image-object-position-with-background-1.html | assertion count 1 is more than expected 0 assertions

RESOLVED FIXED

Status

()

Core
Layout
P3
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell fixed])

Attachments

(1 attachment)

stylo-only

The assertion is

ASSERTION: Disagreement about whether it's a block or not: 'fromLine->IsBlock() == fromLine->mFirstChild->IsBlockOutside()', file /home/worker/workspace/build/src/layout/generic/nsBlockFrame.cpp, line 2877

This looks a lot like bug 1342342 (very similar, but different test name). I think https://hg.mozilla.org/integration/autoland/rev/3c8eff6b0d79bfc9c90ee66b718f6df636bc8354 may have shifted the problem.
Flags: needinfo?(gbrown)
Summary: Intermittent image/image-object-position-with-background-1.html | assertion count 1 is more than expected 0 assertions → Intermittent stylo image/image-object-position-with-background-1.html | assertion count 1 is more than expected 0 assertions

Comment 2

a year ago
24 failures in 181 pushes (0.133 failures/push) were associated with this bug yesterday.  
Repository breakdown:
* autoland: 19
* mozilla-inbound: 4
* mozilla-central: 1

Platform breakdown:
* linux64-stylo: 24

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1343030&startday=2017-03-01&endday=2017-03-01&tree=all
Flags: needinfo?(gbrown)
See Also: → bug 1342188
:emilio - I noticed https://bugzilla.mozilla.org/show_bug.cgi?id=1342188#c1. Is it surprising to still be seeing this assertion (now in a different test)?
Flags: needinfo?(emilio+bugs)
Yeah, that comment was wrong, I just couldn't reproduce locally, but after those patches landed that assertion still appears even for that test case (which is disabled now).

That assertion seems still active, and we need to figure out why :/.

Thanks for pinging though! :)

I have it on the radar, though I'm busy with a bunch of other stuff too.
Flags: needinfo?(emilio+bugs)
Whiteboard: [stockwell needswork]

Comment 5

a year ago
19 failures in 149 pushes (0.128 failures/push) were associated with this bug yesterday.  
Repository breakdown:
* autoland: 12
* mozilla-inbound: 7

Platform breakdown:
* linux64-stylo: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1343030&startday=2017-03-02&endday=2017-03-02&tree=all
Created attachment 8843303 [details] [diff] [review]
allow assertion during test

Thanks for the clarification :emilio.

Since this fails frequently, I'd like to do something to suppress the failures unless a fix for the root cause will be available soon. Skipping the test just seems to "move" the assertion to the next test, but allowing the assertion seems to result in a green run:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cdf4a7d36578df6d676b54000cf8bb27ef2df051
Attachment #8843303 - Flags: review?(emilio+bugs)
Attachment #8843303 - Flags: review?(emilio+bugs) → review+

Comment 7

a year ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bcf89da3a9c0
Modify stylo reftest assert expectations for image-object-position-with-background-1.html; r=emilio
Keywords: leave-open

Comment 8

a year ago
17 failures in 157 pushes (0.108 failures/push) were associated with this bug yesterday.  
Repository breakdown:
* autoland: 14
* mozilla-inbound: 3

Platform breakdown:
* linux64-stylo: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1343030&startday=2017-03-03&endday=2017-03-03&tree=all
Whiteboard: [stockwell needswork] → [stockwell fixed]
76 failures in 783 pushes (0.097 failures/push) were associated with this bug in the last 7 days. 

This is the #14 most frequent failure this week. 

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **

Repository breakdown:
* autoland: 56
* mozilla-inbound: 17
* mozilla-central: 2
* try: 1

Platform breakdown:
* linux64-stylo: 76

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1343030&startday=2017-02-27&endday=2017-03-05&tree=all
Keywords: assertion
Priority: -- → P3
No longer blocks: 1341102
It seems this has been fixed.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.