Run another experiment with automigration on beta 53 to learn more about why users choose not to keep their imported data

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53+ fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1335709 +++

We learned from previous versions of automigration experiments on beta that a significant proportion of users, whose data we automatically migrate from another browser, decide they don't want to keep that data. This is up to 42% of IE/Edge users, and around 32% of Chrome users (https://mzl.la/2lPz8U0 ).

We'd like to understand better why users choose to keep or throw away the data we imported for them, by running another experiment on beta. In bug 1335349, we created the possibility to run a survey from the notification bar when users choose not to keep this data. We have since also had help from Matt Grimes' team to create the survey, and are ready to set this up in time for 53 beta 1.
Comment on attachment 8841942 [details]
Bug 1343080 - enable automigration for beta 53 and show a survey to people who don't keep data,

https://reviewboard.mozilla.org/r/115992/#review117620
Attachment #8841942 - Flags: review?(dolske) → review+
Comment on attachment 8841942 [details]
Bug 1343080 - enable automigration for beta 53 and show a survey to people who don't keep data,

Approval Request Comment
[Feature/Bug causing the regression]: automatic migration testing
[User impact if declined]: can't find out why/when users don't want us to import data
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: n/a
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: we've done 3 of these experiments before now with no ill effects. We're just flipping some prefs, and those won't affect the 53 release (or 53 on aurora, even) - only 53 beta
[String changes made/needed]: none

(needinfo'ing because the last time I did an uplift request like this it got lost because it wasn't marked fixed for current nightly)
Flags: needinfo?(jcristau)
Attachment #8841942 - Flags: approval-mozilla-aurora?
Redirect to Liz and Gerry who take care of 53.
Flags: needinfo?(lhenry)
Flags: needinfo?(jcristau)
Flags: needinfo?(gchang)
Flags: needinfo?(lhenry)
Comment on attachment 8841942 [details]
Bug 1343080 - enable automigration for beta 53 and show a survey to people who don't keep data,

Repeat an experiment for 53 beta, let's give it a try.
Attachment #8841942 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gchang)
Resolution: --- → FIXED
I backed this out of beta today, in time for b7.
You need to log in before you can comment on or make changes to this bug.