All users were logged out of Bugzilla on October 13th, 2018

Image loading pushes the URL's fragment anchor off the screen

RESOLVED DUPLICATE of bug 60307

Status

()

--
minor
RESOLVED DUPLICATE of bug 60307
17 years ago
17 years ago

People

(Reporter: jeremy.vangrinsven, Assigned: attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Loading a page with large images not containing height and width hits causes the
target fragment to be scrolled off bottom the screen.  Using a URL
http://localhost/somepage.html#fragment with the <a name=fragment></a> at the
end of the document with a large <img> above it will show the problem.

I would expect the document to expand around the current viewing position and
not move the document section that is visable as images are loaded and the
document size is changed on re-layout.  Instead it appears to keep a constant
offset from the top of the page and as the page gets longer you see farther up.

Comment 1

17 years ago
could you give a real URL that exhibits this problem, or attach a testcase?

what build are you using?

worksforme with linux build 20020328

Comment 2

17 years ago
Changing QA contact
QA Contact: petersen → moied
(Reporter)

Comment 3

17 years ago
Using build Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020322

I will have to work on a test case to submit.  The page I saw this behavior on
was a private message board that I can't post a link too.  I am not sure how to
simulate the delayed image loading in a local test case.

One key part that I don't think I made clear was the images are much slower to
load and the page gets relayed out several times as they are expanded into the
document.  This is when the view point is shifted.
Duplicate of "Images loading above top of window can cause scrolling up (reflow?)"

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.