WebExtensions should allow for specifying inverted icons

RESOLVED DUPLICATE of bug 1329242

Status

WebExtensions
General
RESOLVED DUPLICATE of bug 1329242
a year ago
2 days ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

WebExtensions have the "icons" property, but it only allows for specifying one style of icon. If the user switches Firefox to use a dark lwt or dark compact mode, then the icon may look out of place while the other icons in the browser switch to become inverted (white).

We should have a second property called "bright-icon" or something better named that is similar to "icons" but allows for specifying the inverted icon.

WebExtensions can implement support for this by keying off of the [brighttext] attribute on the toolbars. If that attribute is set then the inverted icon should be used.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329242

Updated

2 days ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.