The default bug view has changed. See this FAQ.

stylo: Crash [@ nsLayoutUtils::ComputeBSizeValue mozilla::SizeComputationInput::ComputeBSizeValue mozilla::ReflowInput::ComputeMinMaxValues mozilla::ReflowInput::InitConstraints mozilla::ReflowInput::Init]

RESOLVED FIXED

Status

()

Core
General
P1
normal
RESOLVED FIXED
23 days ago
7 days ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 2 bugs, {crash})

unspecified
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 disabled, firefox55 fixed, firefox-esr52 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

23 days ago
Created attachment 8841901 [details]
bughunter stack

found via bughunter and reproduced on latest stylo debug build from tinderbox

STR:
-> Load http://www.tfl.gov.uk
---> Crash

Bobby, this might be related to Bug 1342862 (just that bughunter found this on a topsite during testing) but you said there it should be fixed on m-c (and so on this tinderbox stylo build from taskcluster). Could you take a look ?
(Reporter)

Updated

23 days ago
Flags: needinfo?(bobbyholley)
(Reporter)

Updated

23 days ago
Summary: Crash [@ nsLayoutUtils::ComputeBSizeValue mozilla::SizeComputationInput::ComputeBSizeValue mozilla::ReflowInput::ComputeMinMaxValues mozilla::ReflowInput::InitConstraints mozilla::ReflowInput::Init] → stylo: Crash [@ nsLayoutUtils::ComputeBSizeValue mozilla::SizeComputationInput::ComputeBSizeValue mozilla::ReflowInput::ComputeMinMaxValues mozilla::ReflowInput::InitConstraints mozilla::ReflowInput::Init]
I was under the impression that this would be fixed by bug 1342710. Manish, any thoughts?
Flags: needinfo?(bobbyholley) → needinfo?(manishearth)
I initially thought this was due to width/height being missed by that bug, but that was intentional -- we don't support kw values for w/h yet.

I have to get a new build to try this. In the meantime -- xidorn, have any ideas?
Flags: needinfo?(manishearth) → needinfo?(xidorn+moz)
I did a stylo build with the current m-c, and I failed to reproduce the crash mentioned in comment 0, because it crashes for a different assertion to me:
> thread '<unnamed>' panicked at 'Caller should apply sibling hints', stylo\servo\components\style\data.rs:235
> stack backtrace:
>    0:     0x7ffba552d4ea - std::panicking::default_hook::{{closure}}
>                         at C:\bot\slave\stable-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:354
>    1:     0x7ffba552c756 - std::panicking::default_hook
>                         at C:\bot\slave\stable-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:365
>    2:     0x7ffba553104d - std::panicking::rust_panic_with_hook
>                         at C:\bot\slave\stable-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:553
>    3:     0x7ffba50937ad - std::panicking::begin_panic<&str>
>                         at C:\bot\slave\stable-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:515
>    4:     0x7ffba51d617a - style::data::{{impl}}::from
>                         at C:\mozilla-source\stylo\servo\components\style\data.rs:235
>    5:     0x7ffba543370e - core::convert::{{impl}}::into<style::restyle_hints::RestyleHint,style::data::StoredRestyleHint>
>                         at C:\bot\slave\stable-dist-rustc-win-msvc-64\build\src\libcore\convert.rs:271
>    6:     0x7ffba54cb602 - geckoservo::glue::Servo_NoteExplicitHints
>                         at stylo\servo\ports\geckolib\glue.rs:1244
Flags: needinfo?(xidorn+moz)
With my patch in bug 1340334 this no longer reproduces.
Depends on: 1340334
Blocks: 1343597
Resolving as fixed by bug 1340334 per Emilio's comment 4.
No longer blocks: 1330412
Priority: -- → P1
Status: NEW → RESOLVED
Last Resolved: 9 days ago
Resolution: --- → FIXED
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → disabled
status-firefox55: --- → fixed
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.