Closed Bug 1343247 Opened 3 years ago Closed 3 years ago

[nl] Update searchplugins for Fennec in Dutch

Categories

(Mozilla Localizations :: nl / Dutch, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: delphine, Assigned: delphine)

References

Details

Attachments

(1 file, 1 obsolete file)

As discussed in bug 1115979, we need to update searchplugins for Dutch. At this point, I'll need to add Yahoo and Bing at least. Please read the following for the usual general instructions to determine if you need anything else! :) 

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. , we'll need your input on this, the guidelines for making recommendations are on <https://wiki.mozilla.org/L10n:Mobile/Productization>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia

We may also want to go with just a subset of the en-US engines, if that's more appropriate for the local market.

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. , we'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available. For Android we'll want a specific 96x96px image, with colored background and rounder corners (6px radius).

Once we have a specification on what the search engines for  should look like, Delphine and the localization team will work on the implementation. Delphine will create and attach patches for the desired changes and get them reviewed. After a successful review, Delphine will land them. 

Ton, if you're interested, you could create the patches, too. You'd ask Delphine for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by Delphine, flod, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The  team and Delphine will be driving this bug to completion.
Assignee: dutch.nl → lebedel.delphine
Ton: please let me know if you're OK with the searchengines listed above - or if there's anything else we should add. thanks :)
Flags: needinfo?(tonnes.mb)
> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia

Well, I have some doubts about adding Amazon since as far as I know, it is not a common website to visit for our locale/country.
Additionally I think Yahoo isn’t used here very often either, but I have no insights in market stats (nor the ones for Amazon).
With regards to Twitter, I don’t use it and have no insights either but it may be the best one to add, since one social search is required.

So at first glance, I’d think of 

- Google, Bing, bol.com, Twitter, Wikipedia (nl)

… where DuckDuckGo may be an additional one to add if allowed and to replace Yahoo (total 5 or 6 above?), since FF desktop for our locale and Fennec for some other locales currently use it as well. Not sure what’s needed to add that without the permission?

I’d rather leave patch creation to you, if you don’t mind.

Any thoughts?
Flags: needinfo?(tonnes.mb)
Thanks Ton! Yahoo is required on our side, so I will add that to your list. I can also add DuckDuckgo.

I can work on the patch, no worries :) I'm putting this on my todo list, as well as updating the feed reader protocal handler (might just do this in the same patch here).
Attached patch bug134247.patch (obsolete) — Splinter Review
Again, hoping I can still get this in "the old way" ;) thanks!
Attachment #8848303 - Flags: review?(francesco.lodolo)
Duplicate of this bug: 1115979
Comment on attachment 8848303 [details] [diff] [review]
bug134247.patch

Review of attachment 8848303 [details] [diff] [review]:
-----------------------------------------------------------------

Remember to look out for gecko.handlerService.defaultHandlersVersion when updating an existing locale.

::: mobile/chrome/region.properties
@@ +26,5 @@
>  # cause Firefox to re-read these prefs and inject any new handlers into the
> +# profile database. Note that "new" is defined as "has a different URL"; this
> +# means that it's not possible to update the name of existing handler, so don't
> +# make any spelling errors here.
> +gecko.handlerService.defaultHandlersVersion=1

Don't change this.
Attachment #8848303 - Flags: review?(francesco.lodolo) → review-
Attachment #8848303 - Attachment is obsolete: true
Attachment #8848603 - Flags: review?(francesco.lodolo)
Attachment #8848603 - Flags: review?(francesco.lodolo) → review+
Pushed: https://hg.mozilla.org/releases/l10n/mozilla-aurora/nl/rev/672a422d2919e16d176b931adc229365dd9841a7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.