Forum posts should be displayed oldest first

RESOLVED FIXED

Status

support.mozilla.org - Lithium
Contributor and Question Forums
RESOLVED FIXED
10 months ago
7 months ago

People

(Reporter: madalina, Assigned: scott.riley)

Tracking

Details

(Whiteboard: [1st2weeks])

Attachments

(6 attachments, 2 obsolete attachments)

(Reporter)

Description

10 months ago
Steps to reproduce

Go to the contributor discussion forum: https://support.mozilla.org/t5/SUMO-community-discussions/bd-p/contributors

Click on any topic (for example https://support.mozilla.org/t5/SUMO-community-discussions/Reply-Has-Disappeared-Sent-for-Moderation-After-Edit/m-p/1368423#U1368423)

Actual result
Posts are being displayed by newest first.

Desired result
They should be displayed by oldest first. The way this is set up right now you cannot see the original post.

Couldn't find the setting in the Admin to change this.
(Reporter)

Updated

10 months ago
Assignee: nobody → scott.riley
Status: NEW → ASSIGNED
Whiteboard: [1st2weeks]
(Assignee)

Comment 1

10 months ago
Unless someone has recently made a change, the order is correct when I review these threads.  Admin (for any node you want to check): https://support.mozilla.org/t5/bizapps/bizappspage/tab/community%3Aadmin%3Ainteractions%3Aforums%3Aforum-display . If that is set correctly and you still see it in reverse check personal settings.

Personal Setting: https://support.mozilla.org/t5/user/myprofilepage/tab/user-preferences:linear-format
Flags: needinfo?(mana)
I think this bug may be cleared as worksforme.

I see the thread you mention https://support.mozilla.org/t5/SUMO-community-discussions/Reply-Has-Disappeared-Sent-for-Moderation-After-Edit/m-p/1368423#U1368423 as newest  first, but I Like it that way for a thread I am following and have set that as my preference.
*My preferences show that the default is as you wish it to be* so although I do not see the Admin page I do see the setting and its effects.
> Use default (Oldest first) 


Madalina possibly the not seeing the OP is a separate problem. 
I find that frustrating on threads that are more than one page long.
I think it may be  worth filing a bug so that like Kitsune it always displays the OP {Original Post Message) in a thread or topic as it is called in Lithium even when you are on a second or later page. 
(It would also be useful to show who the OP {User) is especially if the OP Message is not visible. Long threads may often get other users posting in them.)
So I added two screenshots that show the admin preference to change topics and post to displace Oldest first. 

However a user can also change the preferences from the options menu when they open a topic (second option) 
This second use case is taken from the view of a Moderator. Where after the admin was changed that they still had to go in and change the view oldest to newest.
Created attachment 8842649 [details]
oldest first.png
Created attachment 8842650 [details]
2017-03-01_1601.png
Created attachment 8842836 [details]
still wrong order

(In reply to rmcguigan from comment #3)
> So I added two screenshots that show the admin preference to change topics
> and post to displace Oldest first. 
> 
> However a user can also change the preferences from the options menu when
> they open a topic (second option) 
> This second use case is taken from the view of a Moderator. Where after the
> admin was changed that they still had to go in and change the view oldest to
> newest.

Rachel
That example is from my view as a Mod.
However As Far As I Know, those are only my personal settings. They are not a setting I am changing as a Mod.
As I explained earlier I deliberately choose as a Forum User to view them that way.

(From John Hesling [:John99] (NeedInfo me) from comment #2)
> I think this bug may be cleared as worksforme.
> ...
> as newest  first, but I Like it that way for a thread I am following and have set that as my preference.
> *My preferences show that the default is as you wish it to be* so although I
> do not see the Admin page I do see the setting and its effects.
> > Use default (Oldest first) 
> 


NI Rachel.  (Not sure you wish contributors to NI Lithium staff - we were previously asked us to avoid doing that)
Having said that and seeing it work as expected for myself I do not see it work as expected for an ordinary user.
I attach a screen shot of it being in the wrong sort order.
The post topics can be seen to be set to sort oldest to newest - I will attach a screenshot of that next.
The messages or posts themselves can be seen to be in the opposite order to the selection.
Yesterdays  post is at the top.
Mondays post is at the bottom.
I used as an example the Thread | Topic https://support.mozilla.org/t5/SUMO-community-discussions/Being-notified-of-a-new-post-but-it-is-not-there/m-p/1368994#U1368994 Being notified of a new post, but it is not there. because it is unsolved. That rules out the possibility of the solved posts being bumped up to the top as a reason for the latest post being in the wrong position.
Created attachment 8842838 [details]
Thread options show it set oldest to newest, but yesterdays post is at the top

The earlier posts made Tuesday are below this post. Those are older posts and should be on the top.
Created attachment 8842840 [details]
User settings over reiding the default again. That explains initially unexpected results.

OOPS
I do not have bug edit privileges and can not even correct my own bug comments.
Even the ordinary user I was trying had the personal settings set to newest first that the same as my Mods account did.
I will  swap that back to the default setting and all should be as expected again.
Created attachment 8842844 [details]
Worksforme - When personal settings are back to default

This shows the Original Post back on the top, now that personal settings are back to default.
Created attachment 8842847 [details]
(Personal) Linear Settings including confirmation of default being oldest first

As I said a few comments and attachments earlier this works for me.
Main problem is we test with our own personal settings. We do not have additional test accounts or test locations to try things out properly. Some equivalent of Sumo Kitsune Stage|Alizom would be great. As would have been testing pre migration with differing sets of realistic user permissions and settings. 

Mods should not need to set up additional accounts to test as ordinary users, we should have that facility provided as standard.

Can we now close this worksforme 
(There is already an open NI Madalina - no point in adding another)
Attachment #8842836 - Attachment is obsolete: true
Attachment #8842838 - Attachment is obsolete: true
Rachel I forgot to NI you from my comment6
All seems to be working as expected although possibly we may consider filing related bugs for instance to ensure the Initial post is visible on multi page topics, and that the owner  of the topic is clearly identified.
Flags: needinfo?(rmcguigan)
Component: Lithium Migration → Contributor and Question Forums
Flags: needinfo?(rmcguigan)
Product: support.mozilla.org → support.mozilla.org - Lithium
QA Contact: nobody
Guigs, can we close this?
Flags: needinfo?(rmcguigan)
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(rmcguigan)
Flags: needinfo?(mana)
Resolution: --- → FIXED
Created attachment 8867787 [details]
announcement breaks sumo aaq android again

Another announcement. Again it covers the option to ask questions unless you know to request the desktop version of Sumo as a workaround.

I will not even reopen the bug no doubt the announcement will be taken down soon.
But we probably need a better method of making announcements, however possibly the issue will not occur in Lithium.
Oops how did I do that I put it in the  wrong bug.
You need to log in before you can comment on or make changes to this bug.