On changing to "Little Mozilla" checkboxes in pref stop working

RESOLVED WORKSFORME

Status

Core Graveyard
Skinability
--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Whit Blauvelt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020329
BuildID:    2002032911

And after changing back to the Classic theme, the checkboxes still don't work,
even though they were working before switching to Little Mozilla.

Reproducible: Always
Steps to Reproduce:
1.Install nightly build
2.Edit preference and note checkboxes work
3.Switch theme to Little Mozilla and see checkboxes disappear
4.Switch back to Classic and see checkboxes back, but not visible checks and no
ability to check

Comment 1

16 years ago
probably a theme only issue.. with the latest little Mozilla, maybe needs
updating to 1.0 skinver.. and XUL 1.0, switching between classic & modern and
back do not have this problem.. tested on 3-29-16 w2k builds.  
(Reporter)

Comment 2

16 years ago
A theme-only issue, but not limited to a single theme. What makes it more of a
problem is that switching back from the Little Mozilla theme leaves checkboxes
broken in the Classic theme. But I did find that deleting Little Mozilla from
the system restores the checkbox function for Classic. 

Now, shouldn't the logic be that switching from Little Mozilla back to classic
also switches out anything that Little Mozilla breaks? The switch requires
restarting Mozilla, and having something broken in the current theme because of
the last theme that was run ... well, it shouldn't be, it shouldn't matter, and
that deleting Little Mozilla then fixes the problem suggests that Mozilla itself
was still getting values from the theme that wasn't active. 

So it's a theme-swapping issue - themes shouldn't be corruptable by other themes
merely being on the system, or having been used before. 

Comment 3

16 years ago
Please check a recent mozilla build, and the latest little mozilla
skin
theme switsching whie running got disabled - guess why
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.