Closed Bug 1343441 Opened 4 years ago Closed 4 years ago

OSX jemalloc4 logalloc-replay build bustage

Categories

(Core :: Memory Allocator, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1353752

People

(Reporter: RyanVM, Unassigned)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=80745128&repo=try

20:15:16     INFO -  /builds/slave/try-m64-0000000000000000000000/build/src/obj-firefox/memory/replace/logalloc/replay/tmpxeXZYD.list:
20:15:16     INFO -      FdPrintf.o
20:15:16     INFO -      Replay.o
20:15:16     INFO -      Assertions.o
20:15:16     INFO -      ../../../build/mozjemalloc_compat.o
20:15:16     INFO -      ../../../build/mozmemory_wrap.o
20:15:16     INFO -      ../../../build/replace_malloc.o
20:15:16     INFO -      ../../../build/zone.o
20:15:16     INFO -      ../../../build/jemalloc_config.o
20:15:16     INFO -      ../../../jemalloc/Unified_c_memory_jemalloc0.o
20:15:16     INFO -      ../../../jemalloc/Unified_c_memory_jemalloc1.o
20:15:16     INFO -  Undefined symbols for architecture x86_64:
20:15:16     INFO -    "__malloc_postfork_child", referenced from:
20:15:16     INFO -        _zone_force_unlock in zone.o
20:15:16     INFO -        _zone_reinit_lock in zone.o
20:15:16     INFO -    "__malloc_prefork", referenced from:
20:15:16     INFO -        _zone_force_lock in zone.o
20:15:16     INFO -  ld: symbol(s) not found for architecture x86_64
20:15:16     INFO -  clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
20:15:16     INFO -  ../../../../../../../config/nsinstall -L /builds/slave/try-m64-0000000000000000000000/build/src/obj-firefox/toolkit/crashreporter/google-breakpad/src/tools/mac/dump_syms -m 755 'dump_syms' '../../../../../../../dist/host/bin'
20:15:16     INFO -  make[5]: *** [logalloc-replay] Error 1
20:15:16     INFO -  make[4]: *** [memory/replace/logalloc/replay/target] Error 2

I haven't had a chance to try bisecting this yet. Just noticed it while testing out the new 4.5.0 release today.
Looks like Alex filed this again, but with a fix included.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353752
No longer blocks: jemalloc4-by-default
You need to log in before you can comment on or make changes to this bug.