"override colors specified by the page" has problems

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Lu Wei, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8842306 [details]
amazon.JPG

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I'd like to replace the white background with a greenish color. 
Options->Content->Colors...->Background, select a light green color, "Override the colors..." select "Always".


Actual results:

The page background changed, but with some other elements disappeared, or changed appearance. As the attached screen shot, Amazon: banner, cart icon, search button, category icon "<",  star indicator, etc are gone.


Expected results:

Only page background color should change.

Updated

a year ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true

Comment 2

a year ago
There's no way for Firefox to know whether CSS that specifies a background image should be overridden or not. Because this is first and foremost an accessibility-related setting, it errs on the side of caution and overrides everything, including CSS background images. This is expected.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.