WebM video seekbar is displayed like in a live video

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
a year ago
11 months ago

People

(Reporter: emilghitta, Unassigned)

Tracking

8 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr45 wontfix, firefox51 wontfix, firefox52 wontfix, firefox-esr52 wontfix, firefox53 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8842362 [details]
Seekbar issue

[Affected versions]:
Latest Nightly 54.0a1 
Firefox 45.8.0 
Firefox 52.0b9 
Firefox 51.0.1 

[Affected platforms]:
Ubuntu 14.04 x86
Windows 10 x64
Mac 10.11.6

[Unaffected platforms]:
Windows 7 x64.

[Steps to reproduce]:
1.Launch mozilla firefox 45.8.0.
2.Access the http://video.webmfiles.org/big-buck-bunny_trailer.webm weblink.
3.Observe that the seekbar is displayed like in a live video.

[Expected result]:
The seekbar is displayed properly.

[Actual result]:
The seekbar is displayed like in a live video.

[Regression range]:
I didn’t manage to discover the regression range for this issue, but i will come back to this as soon as possible.

[Additional information]:
Please note that you may have to refresh the webpage in order to reproduce this issue
Flags: needinfo?(emil.ghitta)
Component: Audio/Video → Audio/Video: Playback
This issue goes back as far as FF 13.0 (Maybe even further but that is all I have locally on my machine).

Comment 2

a year ago
I cannot reproduce it in Fx52.0, 45.7.0esr and 54.0a1 (2017-03-04) (32-bit) on Win10.
Component: Audio/Video: Playback → Video/Audio Controls
Product: Core → Toolkit

Comment 3

a year ago
I cannot make the video display as a live video, always get total time after refresh. 

Changing component back to audo/video playback as video controls' display varies according to what (meta)data it got, I guess total time should not be "unknown" to video controls in this case.
Component: Video/Audio Controls → Audio/Video: Playback
Product: Toolkit → Core
(Reporter)

Comment 4

a year ago
This seems to be an old regression:
Last good revision: a43c3080f472 (2011-08-02)
First bad revision: 3735fb1cd5ef (2011-08-03)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a43c3080f472&tochange=3735fb1cd5ef
Flags: needinfo?(emil.ghitta)
(Reporter)

Updated

a year ago
Keywords: regressionwindow-wanted → regression
Bug 619752 in that range looks relevant.
status-firefox51: affected → wontfix
status-firefox52: affected → wontfix
status-firefox53: affected → fix-optional
status-firefox55: --- → affected
status-firefox-esr45: affected → wontfix
status-firefox-esr52: --- → wontfix
Version: Trunk → 8 Branch
Given that this regression is so old, let's just treat it as a regular bug.
status-firefox53: fix-optional → wontfix
status-firefox54: affected → ---
status-firefox55: affected → ---
Keywords: regression
I'm guessing it is an issue with the webm file itself but the file is no longer available.
Can you provide another WebM file that reproduces the bug?
Flags: needinfo?(emil.ghitta)
(Reporter)

Comment 9

11 months ago
It seems that I no longer reproduce this issue with other WebM files. I will mark this issue as WORKSFORME (feel free to change this if you encounter this issue).
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.