Closed Bug 1343490 Opened 4 years ago Closed 4 years ago

Firefox (new versions) visible slower than older versions

Categories

(Firefox :: Untriaged, defect)

51 Branch
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: solo_manro, Unassigned)

Details

(Whiteboard: [qf:p3])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Browsing different pages



Expected results:

How it is possible that a very old version of Firefox(ex.17.0.1) to be much faster than earliaer versions (ex.51.0.1) ??

https://sendvid.com/jmbonlgg
Could you please capture your profile using the addon found here:

https://perf-html.io/

please paste your results when finished.
Flags: needinfo?(solo_manro)
[bugday-20170306]
Seems to be duplicate of 1334367. The bug is not yet resolved with firefox 51.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334367
(In reply to Justin [:JW_SoftvisionQA] from comment #1)
> Could you please capture your profile using the addon found here:
> 
> https://perf-html.io/
> 
> please paste your results when finished.

Here are the results. The capture was made on a clean profile for Fx 51 (like in the movie).
Unfortunately Gecko Profiler is not available for Firefox 17 but the test from the movie was made also in clean profile-(except the "Zoom Page WE" addon).
https://perf-html.io/public/d82c4266475db313a0c7628fb939f7a83cab50ef/calltree/?thread=3
Thank you for the profile and the video, decebalus.

Hey jrmuizel, any ideas what decabalus might be running into here? I see a bunch of page JS blocking the main thread in the profile - looks like advertising script. Mostly these appear to be firing off of timers. I also see periodic sync IPC messages for things like PScreenManager. I see frequent painting. But not one thing seems to be clearly dominating this profile, at least to my eyes.
Flags: needinfo?(jmuizelaar)
Tested and retested again on a dozen of pages and the result is the same, Fx 17 is much faster than 51 in more than 90 % of cases. Indeed for Fx 17 some pages are not correctly displayed or missing elements due to the very old code, but on the average, this is the result.
Maybe you wonder why Fx 17.? I reported some time ago a bug from Facebook wich in fact is a duplicate of bug 1131937. Then somebody ask me to do a mozregression, I do it and the result is that the last version where this bug is not present is 17.0.x. Then playing a little with fx 17 I noticed that is speedy than the current version I use daily, so I thought do do a test in parallel.
I think this issue is wrong classified like duplicate of bug 1334367 because here the test is made on clean profile and the "issue" can't be related to addons or to high CPU usage..I think the problem is the whole conception of the new Firefox. I tested also Fx 52 vs 17 and is the same result, Fx 17 is about 30 % faster than 52 and in some cases even 50%. Anybody can can check this by browsing 10-15 randoom pages. Like a regular user I am, I'm wonder for what a lot of work and years spended, if the new versions are slower than the older? (except the security, about I don't care too much, because I have a good AV)
Can you reproduce the problem without dev tools and firebug? Which page is the problem most noticeable on?
Flags: needinfo?(jmuizelaar)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #7)
> Can you reproduce the problem without dev tools and firebug? Which page is
> the problem most noticeable on?

It can be always reproduced but indeed the differences are not so big without Devtols and firebug, but they exist.  From all these pages from the following video just one was loaded faster on Fx 52 (www.politics.ie).
Note that Fx 52 was in advantage each time (first run). I can't say about one page with most noticeable problem, but I think on heavy loading pages( with a lot of advertising) the difference is bigger. The idea is that Fx 50/51/52 are slower than Fx 17 wich is very funny.
https://streamable.com/d663u
(In reply to Jeff Muizelaar [:jrmuizel] from comment #7)
> Can you reproduce the problem without dev tools and firebug? Which page is
> the problem most noticeable on?

Other links:
https://streamable.com/0659h
Not a dupe
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
any update on this?
Hey decebalus, can you go to about:support and click "Copy text to clipboard" and paste the contents here? It might help us diagnose why you're seeing this problem.
Application Basics
------------------

Name: Firefox
Version: 52.0.2
Build ID: 20170323105023
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Application Update Service Helper
Version: 2.0
Enabled: true
ID: aushelper@mozilla.org

Name: Multi-process staged rollout
Version: 1.9
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Site Deployment Checker
Version: 1.0
Enabled: true
ID: deployment-checker@mozilla.org

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: Bitdefender Wallet
Version: 4.2.4
Enabled: false
ID: bdwteffv20@bitdefender.com

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; D3D11 blacklisted with DLL igd11dxva64.dll (20.19.15.4444); Using D3D9 API
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.14393.953)
GPU #1
Active: Yes
Description: NVIDIA GeForce GT 610
Vendor ID: 0x10de
Device ID: 0x104a
Driver Version: 21.21.13.7653
Driver Date: 12-29-2016
Drivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispiwu.inf_amd64_b67dc924fff8de6d\nvwgf2um
Subsys ID: 36481458
RAM: 2048

Diagnostics
ClearType Parameters: Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
ClearType Parameters: Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.search.update: false
browser.sessionstore.upgradeBackup.latestBuildID: 20170323105023
browser.startup.homepage_override.buildID: 20170323105023
browser.startup.homepage_override.mstone: 52.0.2
browser.tabs.loadInBackground: false
browser.tabs.remote.autostart.2: true
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20170319
browser.urlbar.suggest.bookmark: false
browser.urlbar.suggest.openpage: false
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 52.0.2
gfx.crash-guard.d3d11layers.appVersion: 52.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x104a
gfx.crash-guard.d3d11layers.driverVersion: 21.21.13.7653
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d11video: 2
gfx.crash-guard.status.d3d9video: 2
gfx.direct3d.last_used_feature_level_idx: 0
media.benchmark.vp9.fps: 151
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86_64-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1489487480
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1489487480
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170323105023
media.gmp-manager.lastCheck: 1491902493
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1489487481
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1491902667
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.formdata: false
privacy.clearOnShutdown.history: false
privacy.clearOnShutdown.offlineApps: true
privacy.clearOnShutdown.sessions: false
privacy.cpd.cookies: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.sanitizeOnShutdown: true
security.default_personal_cert: Select Automatically
security.OCSP.enabled: 0
security.sandbox.content.tempDirSuffix: {ff6d9258-2696-4a2d-b6f2-de471b1676b2}
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1489488251
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.28.3
Version in use: 3.28.3

NSSSMIME
Expected minimum version: 3.28.3
Version in use: 3.28.3

NSSSSL
Expected minimum version: 3.28.3
Version in use: 3.28.3

NSSUTIL
Expected minimum version: 3.28.3
Version in use: 3.28.3

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1
Flags: needinfo?(solo_manro)
Whiteboard: [qf] → [qf:investigate:p1]
Same slowness for Firefox 53.
Whiteboard: [qf:investigate:p1] → [qf:p3]
Is there any update on this issue?
Closing due to lack of response.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.