Firefox will crash after dismissing the context menu and changing device orientation

VERIFIED FIXED

Status

()

P1
critical
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: SimonB, Assigned: bmunar)

Tracking

({crash, reproducible})

unspecified
All
iOS
crash, reproducible

Firefox Tracking Flags

(fxios-v7.0 verified, fxios7.0+, fxios-v8.0 fixed)

Details

(Whiteboard: [MobileCore])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8842418 [details]
Client  01-03-2017, 16-18.crash

Build: d66101cc
Device: iPad Air 2
iOS: 10.2

Steps to reproduce:
1. Go to youtube.com
2. Long tap on a link to open the context menu
3. Dismiss the context menu by tapping on on the page
4. Change device orientation

Actual results: 
- Firefox will crash

Note: 
- This is a posible swift 3 migration regression
- Issue reproducible only on iPads
Moving to 7.0/P1 since this is an easy-to-reproduce regression crasher.
tracking-fxios: ? → 7.0+
Priority: -- → P1
Whiteboard: [MobileCore]
(Assignee)

Updated

2 years ago
Assignee: nobody → bmunar
(Assignee)

Comment 2

2 years ago
Created attachment 8843509 [details] [review]
PR

I can't believe I did not catch this until now LO L OL OL
(Assignee)

Updated

2 years ago
Attachment #8843509 - Flags: review?(sleroux)
Attachment #8843509 - Flags: review?(sleroux) → review+
(Assignee)

Comment 3

2 years ago
https://github.com/mozilla-mobile/firefox-ios/pull/2492/commits/ec756474bc7025f40ef88d31d201487a083d1367
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
v7.x fcecaaec2c8ecb9baafa4e5b60e9c0763a20d51c
status-fxios-v7.0: --- → fixed
status-fxios-v8.0: affected → fixed
(Reporter)

Comment 5

2 years ago
Verifying as fix on 7.0b1986.
Status: RESOLVED → VERIFIED
status-fxios-v7.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.