Pin bmo es etl pypy in puppet

RESOLVED FIXED

Status

Developer Services
General
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: dhouse, Assigned: dhouse)

Tracking

Details

Attachments

(2 attachments)

(Assignee)

Description

11 months ago
We need to keep the custom pypy build on the bmo elasticsearch ETC batch/script server. Pinning it in puppet would prevent it from being "upgraded" to an older version.
(Assignee)

Comment 1

11 months ago
Need to pin:
pypy-2.2.1-moz0.x86_6
pypy-libs-2.2.1-moz0.x86_64
(Assignee)

Comment 2

11 months ago
on host:
etl1.bugs.scl3.mozilla.com
(Assignee)

Updated

11 months ago
No longer blocks: 1339806
See Also: → bug 1339806
(Assignee)

Comment 3

10 months ago
The current pypy packages are the correct version:
[dhouse@etl1.bugs.scl3 ~]$ rpm -q pypy pypy-devel pypy-libs
pypy-2.2.1-moz0.x86_64
pypy-devel-2.2.1-moz0.x86_64
pypy-libs-2.2.1-moz0.x86_64
(Assignee)

Comment 4

10 months ago
Created attachment 8847141 [details] [diff] [review]
bug1343566_pin-pypy-for-etl.patch
Attachment #8847141 - Flags: review?(klibby)

Comment 5

10 months ago
Comment on attachment 8847141 [details] [diff] [review]
bug1343566_pin-pypy-for-etl.patch

Review of attachment 8847141 [details] [diff] [review]:
-----------------------------------------------------------------

Using ensure on the package version won't prevent us from accidentally upgrading pypy, it will just downgrade it on the next puppet run. That's probably acceptable on this host; if the cron job fails for 30-60 minutes it's unlikely that anyone will notice. 

If you want to go the extra step, util::lock_package will prevent us from upgrading.
Attachment #8847141 - Flags: review?(klibby) → review+
(Assignee)

Comment 6

10 months ago
Thank you for pointing that out! I'll add the lock_package setting so that it doesn't get upgraded. I don't want for a downgrade to be needed since there could be problems/failures with that.
(Assignee)

Comment 7

10 months ago
Created attachment 8848198 [details] [diff] [review]
bug1343566_pin-pypy-for-bmo-es-etl.patch

Confirmed works when running against etl (versionlock was installed automatically by puppet once the util:lock_version was used):
[dhouse@etl1.bugs.scl3 ~]$ sudo yum versionlock
Loaded plugins: rhnplugin, security, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
0:pypy-2.2.1-moz0.*
0:pypy-devel-2.2.1-moz0.*
0:pypy-libs-2.2.1-moz0.*
versionlock list done
Attachment #8848198 - Flags: checked-in+
(Assignee)

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.