Closed Bug 134359 Opened 18 years ago Closed 17 years ago

microsoft.com - they use document.all (surprise, surprise)

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 148008

People

(Reporter: info, Unassigned)

References

()

Details

you can see that you cant click to enter any of download or others links
Reporter, what build are you using?
Summary: cat enter to some links → cat enter to some links
Summary: cat enter to some links → can't enter to some links
The reason Downloads, White Papers and some other link don't work is that the
page contains invalid code -- it's not Mozilla's fault. Reporter, you might want
to read http://www.mozilla.org/quality/bug-writing-guidelines.html before you
file any more bugs. Thanks for your help with testing Mozilla!

Technical description (you can skip this if you're not interested):

The downloads and the other links are <a> elements without any 'href'. The page
contains some JavaScript which captures every click and figures out whether you
just clicked on one of those links. If you did, the following code is executed:

srcID = srcElement.id.substr(0, srcElement.id.length-1);
targetElement = document.all(srcID + "s");
srcElement = document.all(srcID + "i");

Mozilla doesn't support document.all since it is not part of the W3C DOM, so
this bug is invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
reopening.  
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Jonas, thanks for the analysis.  Over to evangelism to fix this site to work 
with browsers other than IE (fat chance...)
Assignee: asa → doronr
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Hardware: PC → All
Version: other → unspecified
Updating summary and adding to microsoft.com tracker.
Blocks: MS
Summary: can't enter to some links → microsoft.com - they use document.all (surprise, surprise)
->evang500
Keywords: evang500
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us
This page seems to work now.  I can't say for certin b/c the lack of detail from
the reporter.  
fixed
wfm 2003082005 Linux.

*** This bug has been marked as a duplicate of 148008 ***
Status: NEW → RESOLVED
Closed: 18 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.