Allow to open an close sidebars automatically

RESOLVED DUPLICATE of bug 1341126

Status

()

Toolkit
WebExtensions: Untriaged
--
enhancement
RESOLVED DUPLICATE of bug 1341126
6 months ago
10 days ago

People

(Reporter: sebo, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [design-decision-denied], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Some extensions require to open sidebars automatically based on the URL the user is on or other criteria.

See https://addons.mozilla.org/firefox/addon/mdn-documentation-tester for example.

Therefore, there should be a way to toggle sidebars from within the extension.
This could either happen via a manifest property holding a regular expression for URL-matching, or, to be more flexible, via an API like in the Add-on SDK[1].

Sebastian

[1] https://developer.mozilla.org/en-US/Add-ons/SDK/Low-Level_APIs/ui_sidebar
(Reporter)

Updated

6 months ago
Keywords: dev-doc-needed

Updated

6 months ago
Whiteboard: [design-decision-needed]
See Also: → bug 1341126

Updated

6 months ago
Depends on: 1329022
No longer depends on: 1208596
Created attachment 8844117 [details]
WebNotification-Options.PNG

This seams to be very powerful, and potentially annoying for people. And it seams that the example could well work without the sidebar being opened automatically.

If we intend to do this, it should be an optional permission that the user has to grant once before the sidebar can be opened, and an option to easily revoke that permissions from the open sidebar. Similar to how we implemented Web Notifications - see attachment.
Hi Sebastian, this has been added to the agenda for the April 25 WebExtensions Triage meeting. Would you be able to join us to discuss the bug? 

Call-in info and time: https://wiki.mozilla.org/Add-ons/Contribute/Triage#Details_.26_How_to_Join

Agenda: https://docs.google.com/document/d/1WScwIH2D5tiL7vT4_lC44oFigR53xatWsUEwyjWvs7k/edit#
I'm highly inclined to dup this to bug 1341126.
(Reporter)

Comment 4

4 months ago
Thanks for the invitation, Caitlin! Can't promise, but I'll try to be there that day.

Sebastian
(Reporter)

Comment 5

4 months ago
(In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> I'm highly inclined to dup this to bug 1341126.

Skimming that bug quickly my issue looks to be covered by it, yes. So, it exposes a function toggleSidebar() allowing to open and close the sidebar, right? I'd still be happy to discuss this shortly in the triage meeting.

Sebastian

Comment 6

4 months ago
As mentioned here https://bugzilla.mozilla.org/show_bug.cgi?id=1341126#c9 there should be an API allowing to read the current state (opened, closed) of the sidebar in a specific window. Then together with the toggle function it should be complete.
(In reply to Sebastian Zartner [:sebo] from comment #5)
> (In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> > I'm highly inclined to dup this to bug 1341126.
> 
> Skimming that bug quickly my issue looks to be covered by it, yes. So, it
> exposes a function toggleSidebar() allowing to open and close the sidebar,
> right? I'd still be happy to discuss this shortly in the triage meeting.
> 
> Sebastian

It only allows it based on user action, so it doesn't cover this use case exactly.
(Reporter)

Comment 8

4 months ago
(In reply to Shane Caraveo (:mixedpuppy) from comment #7)
> (In reply to Sebastian Zartner [:sebo] from comment #5)
> > (In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> > > I'm highly inclined to dup this to bug 1341126.
> > 
> > Skimming that bug quickly my issue looks to be covered by it, yes. So, it
> > exposes a function toggleSidebar() allowing to open and close the sidebar,
> > right? I'd still be happy to discuss this shortly in the triage meeting.
> > 
> > Sebastian
> 
> It only allows it based on user action, so it doesn't cover this use case
> exactly.

Ok, so it sounds like this bug should be kept separate then, but we can discuss this in the triage meeting next week.

Sebastian
Hi all -- I am confirming that this bug is on the agenda for the May 2 WebExtensions Triage meeting. 

Wiki: https://wiki.mozilla.org/Add-ons/Contribute/Triage#Next_Meeting

Agenda: https://docs.google.com/document/d/1vf8AaW8tKKbMn4KhsqEYhrYqVTUGaERHQmzanEp2Cls/edit#

Sebastian, I hope you can make it again!

Comment 10

4 months ago
> It only allows it based on user action, so it doesn't cover this use case exactly.

Then I actually misunderstood the other patch and therefore I'm strongly advocation for this bug being implemented.

I'm developing a vertical tab add-on and it's an UX disaster if the tab sidebar gets closed by e.g. opening another sidebar without that the tab sidebar is being reopened automatically when the other sidebar is closed. (Would be nicer to have multiple sidebars anyway, but this is another bug).

Also on startup the tab sidebar should be opened automatically. Users do expect that their tabs are always there without requiring manual user actions.
(Reporter)

Comment 11

4 months ago
For reference, here's the URL to the source code of the MDN documentation tester extension mentioned in comment 0:

https://github.com/Elchi3/mdn-doc-tests

Sebastian

Comment 12

4 months ago
There was quite a bit of concern about this in the meeting, in particular:
* the changing of the UI in Firefox without a user action (something we've avoided as much as possible)
* the jank and resizing that occurs each time the sidebar is opened
* given that only one sidebar can be open at a time, the ability of add-ons to "fight" over the sidebar is a concern

A few useful things did come out of the chat:
* an API to query what sidebar is open would be very useful, probably limited to those 
* more APIs to allow the sidebar on user interaction would be good for example:
  * opening on a browser action
  * opening on a context menu and so on

Based on that we are going to turn this down, but would like to spawn some new bugs to make sidebars easier to work with.

Croydon, as for comment 10, as far as I know if Firefox is shut down and re-opened the same sidebars are re-opened. At least they are for me. If not that's a bug let's get that one on file.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
Whiteboard: [design-decision-needed] → [design-decision-denied]
Keywords: dev-doc-needed

Updated

11 days ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1341126
You need to log in before you can comment on or make changes to this bug.