Closed Bug 1343920 Opened 5 years ago Closed 5 years ago

Headset unplugging/plugging results in audio playback despite video being muted

Categories

(Core :: Audio/Video: cubeb, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 --- wontfix
firefox-esr52 --- verified
firefox53 --- verified
firefox54 --- verified
firefox55 --- verified

People

(Reporter: emilghitta, Assigned: achronop)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
Firefox 52.0b2 (Build Id:20170130065342)
Firefox 52.0b9 (Build Id:20170223185858)
Firefox 54.0a1 (Build Id:20170302030206)
Firefox old Nightly 52.0a1 (Build Id:20161022030204)
Firefox 52.0b1 (Build Id:20170124094647)
Firefox ESR 52.0 (Build Id:20170227085837)


[Affected platforms]:
MacOS


[Steps to reproduce]:
1.Launch Firefox.
2.Access the https://www.youtube.com/watch?v=gjQmTkMjIBg weblink (or any YouTube video).
3.Mute the video.
4.Unplug headphones.
5.Plug headphones.
6.Click on the Play button.
7.Observe that the video resumes and the audio is outputted in the headphones even tho the video is muted.

[Expected result]:
The video continues to play but the audio is muted.

[Actual result]:
The video continues to play but the audio is outputted even tho the video is displayed as muted.

[Regression range]:
This is an old regression:
The latest good build is old Nightly from 2016-10-21
The first bad build is old Nightly from 2016-10-22
Pushlog:https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f0f1aaf051d6798e1e73d1feee07ca847333167a&tochange=5639a9f476d08f300c079117e61697f5026b6367

[Additional information]:
This issue is reproducible using headphones that are connected via jack or USB.

This issue is not reproducible on Windows and Linux.

Please note that this issue does not affect Firefox 51.0.1,Firefox old Nightly from 2016-10-21 and Firefox ESR 45.8.0.
Keywords: regression
Component: Audio/Video → Audio/Video: Playback
Component: Audio/Video: Playback → Audio/Video: cubeb
Chunmin,
Can you check this bug?
Flags: needinfo?(cchang)
There is already a fix about it in cubeb repo will be imported with next update
Flags: needinfo?(cchang)
Assignee: nobody → achronop
Depends on: 1345049
(In reply to Alex Chronopoulos [:achronop] from comment #2)
> There is already a fix about it in cubeb repo will be imported with next
> update
Cool!
Rank: 15
Priority: -- → P1
Bug 1345049 has landed on trunk, so this should be fixed there. Can you please confirm that, Emil?
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → FIXED
I continue the discussion from bug 1345049. My colleague Paul can also verify the fix. Actually there is a case that it can fail silently. Can you please capture logs, MOZ_LOG=cubeb:4 ?
Flags: needinfo?(ovidiu.boca)
Attached file MOZ_LOG=cubeb:4.txt
Thanks Alex for guidance, please see the .txt file with the logs. Feel free to contact me.
Flags: needinfo?(ovidiu.boca)
Does this bug need reopening then?
Flags: needinfo?(achronop)
I'm working with Ovidiou to finger out what is going on. I know it works for me and Paul. I don't see anything failing in the logs. Ovidiu will test with different laptop and headset in case we finger out something from there. Once we define the error I will reopen the bug if that's the case.
Flags: needinfo?(achronop)
Landed to 55, 54, 53 with Bug 1345049
I have verified that the issue is not reproducible anymore using Firefox 53.0 (Build Id:20170413192749), Firefox 52.0.2esr (Build Id:20170323110425), Firefox 54.0b1 (Build Id:20170420011827) and Firefox 55.0a1 (Build Id:20170420030346) on macOS 10.11.6.
Status: RESOLVED → VERIFIED
Flags: needinfo?(emil.ghitta)
Duplicate of this bug: 1354827
You need to log in before you can comment on or make changes to this bug.