Nubis: website content is not updating in prod

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: danielh, Unassigned)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/4349])

(Reporter)

Description

2 years ago
I discovered that the TLS Canary and Planet websites that I deployed with Nubis are not updating website content in prod. Stage is working as expected. This will require some investigation to find the root cause and deploy a fix.

https://github.com/mozilla-it/nubis-tlscanary-mozilla-org/issues/31
https://github.com/mozilla-it/nubis-planet-mozilla-org

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/4349]

Updated

2 years ago
Assignee: server-ops-webops → dhartnell
(Reporter)

Comment 1

2 years ago
A fix has been pushed which has closed out this issue on the TLS Canary site. I'll wait for new content to be added to the source repository in order to  validate the fix. This seems to happen several times per month and I expect another one within a few days.

I don't think the Planet site uses the same script to update the site content. I'll need to evaluate that one separately to identify the underlying problem. Since they have the same problem, I suspect the causes are relatively similar.
(Reporter)

Comment 2

2 years ago
This is resolved on TLS Canary:
https://www.tlscanary-prod.prod.us-west-2.tlscanary.nubis.allizom.org/

You can't really see much. The latest update was yesterday which means that the site was able to successfully run "git pull".
(Reporter)

Comment 3

2 years ago
I have not been able to identify the underlying issue which is preventing Planet from updating. At this point, I think that the planet.sh script is executing when it should but we're not generating new content. Possibly due to network connectivity? I'll need elevated access to the host in order to gather new information. I'll post an update once I have it.
(Reporter)

Comment 4

2 years ago
Recent changes have impacted my access to Jenkins and that means I'll need to postpone this work. I want to leave this bug open and I'll come back to it as soon as I can.
(Reporter)

Updated

2 years ago
Depends on: 1341413

Updated

a year ago
Assignee: dhartnell → server-ops-webops
(Reporter)

Comment 5

a year ago
I'm closing this as won't fix. Since this bug was created, the Nubis team created Haul for hosting static websites. We are moving Planet from the account noted here to Nubis Haul in bug 1385024. That should resolve the issue described here.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Updated

a year ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

a year ago
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.