Closed Bug 1343997 Opened 5 years ago Closed 5 years ago

Difference of implementation of WebRequest ResourceType "types" property between Firefox and Chrome

Categories

(WebExtensions :: Untriaged, defect)

54 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1343996

People

(Reporter: imprec, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170302030206

Steps to reproduce:

I wrote the following code use ResourceType (https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/webRequest/ResourceType)

```
chrome.webRequest.onCompleted.addListener((details) => console.log('onCompleted', details.url), { urls: ['<all_urls>'], types: [] });

fetch('https://blackfire.io');
```

On Chrome, the `console.log` call is triggered, because Chrome considers the "types" property that equals to an empty array as "all types"

On Firefox result is different:



Actual results:

No console.log is triggered, the event is not caught


Expected results:

As a an experimented Chrome extension developer, I expected my code work.
I realized I should remove the "types" property to match any request type
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1343996
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.