Mouse scroll wheel goes whacky

RESOLVED DUPLICATE of bug 33732

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 33732
16 years ago
15 years ago

People

(Reporter: Sveinbjorn Thordarson, Assigned: joki (gone))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031106

I have set my mouse scroll wheel to scroll 2 lines of document in the Advanced
-> Mouse wheel settings.  However, when I visited the very site I am submitting
this on the functionality of the scroll wheel seems to have changed:  It now
selects text.  I am, of course, using a Mac with a three button mouse with
scroll wheel using the USB Overdrive package to enable more than one button. 
However, USB Overdrive only makes the mouse send MacOS events and shouldn't
interfere with Mozilla any more than it does with other applications, with whom
it works just fine.

Reproducible: Always
Steps to Reproduce:
1.Visit http://www.mozilla.org/quality/help/bugzilla-helper.html
2.Try to scroll down
3.

Actual Results:   Voila, a bunch of text gets selected instead of me scrolling
further down the page.

Expected Results:  Scrolled down the page as it is set to do.  Instead the
scroll wheel selects some text, or even worse, does nothing at all.

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Comment 1

16 years ago
If you first click somewhere in the page, does it scroll like it should then?
(possible dup of bug 33732 - many wheelscroll bug-reports about same page have
been resolved as dups of that one.)

Comment 2

16 years ago
No word from reporter. Resolving as dup.

*** This bug has been marked as a duplicate of 33732 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.