The entire top of the page is missing.

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
16 years ago
12 years ago

People

(Reporter: Lewis Kopp, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020329
BuildID:    2002032915

When I go to www.apple.com, the entire top of the page is missing.  The only
part that displays is the bottom portion from the search text box down, although
the search button itself is also missing.  Also, the "Powered by Mac OS X
Server" logo is missing at the very bottom of the page.  None of the navigation
tabs at the very top or the pictures are displaying.  As I move the cursor
around the top, the buttons are invisible but there.  When I go click on one of
the buttons, it takes me to the appropriate page but, once again, the pictures
are missing.

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla
2. Go to www.apple.com
3.

Actual Results:  I get the results as described in the above Description

Expected Results:  Mozzilla should have displayed the navigation tabs & bars and
pictures at least.  The page should look something like what Netscape 4.71 &
iCab 2.7.1 display for the same page.

I'm using OS X 10.1.3, on a 733MHz G4 with the original AGP Radeon graphics
card.  I have 768MB of RAM.

This problem also occurs in the milestone release of Mozilla 0.9.9 for OS X.

Comment 1

16 years ago
WFM 2002032916
Do you allow all images? Or only images from the originating server?  Apple's 
images come from a server that's not apple.com.

Comment 3

16 years ago
yeah, looks fine in:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+) Gecko/20020326

Could be a regression, but my guess is that its something easier. Seems like all
the "missing" portions of the page are images served from akamai.net, so I'd
guess either:

a: the akamai server was temporarily down.

or

b: the reporter as set "Accept images from originating server only" in their
Pirvacy Preferences as the previous poster stated
(Reporter)

Comment 4

16 years ago
You figured it out, folks!  It turns out that I did have it set to not accept images from other than the originating server. :-}  I just found where I can set specific URL's that I don't want to accept images from.   With those set I won't mind having 3rd party images turned on.

Thanks for the help! :-)
Lewis, great to hear that.  :)  I'm going to mark this bug as invalid, since 
Mozilla was in fact doing exactly what it was supposed to.  Please don't let 
this discourage you from filing bugs or anything silly like that; keep 'em 
coming.

Thanks,
Boris
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
I do find it odd that not even the ALT text is being rendered in these cases. Is
there a separate bug out there for that? Does an evangelical type person want to
let the good folks at apple that there is the potential that 98% of their homepage
would be blank in Mozilla? 

I'm sure we can make /something/ out of this bug.
> I do find it odd that not even the ALT text is being rendered in these cases.
> Is there a separate bug out there for that?

Yep.  Bug 41924 (bug 88722 is one of the many dups of that).

And the people at Apple do know.  I mailed them at some point after the third 
report I saw on this problem in Bugzilla.  They're not likely to stop using 
akamai's services, however.  It's too big a win.
(Reporter)

Comment 8

16 years ago
I tend to agree with Chris, I think it should at least display the placeholders - which is what iCab does.

And now that I've figured out how to filter out the ads, I'll be using it a whole lot more - so I'll have even
more of an opportunity to find bugs. ;-)  I did have another one today as well - #134412.  That one IS a
genuine bug, I believe.  But it isn't super easy to duplicate unless you're using a pen on a  graphics tablet - 
which is my standard mode.

Thanks again!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.