Closed Bug 1344150 Opened 5 years ago Closed 5 years ago

Audio only plays once after captureStream

Categories

(Core :: Web Audio, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1337653
Tracking Status
firefox51 --- affected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected

People

(Reporter: nielsklom2, Unassigned)

Details

User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.1.50 (KHTML, like Gecko) CriOS/56.0.2924.79 Mobile/14D27 Safari/602.1

Steps to reproduce:

I made a demo for this for an article I was writing.
See: klombomb.github.io/simple-daw 
On pressing keys K,C,S,H sounds should play, however they only play once,
After which the audio is muted. The audio elements are hooked up to an Audio Context
and then to a Media Recorder. If I leave the Web Audio code out it works fine.
This bug was found in FF for Ubuntu, the latest version. It worked fine in previous ones and in Nightly it still does.


Actual results:

Sound muted after first play.


Expected results:

Not be muted.

(With muted I mean that you can't hear it, the audio element is 
not actually muted.)
Update: the correct link for the demo is https://klombomb.github.io/simple-daw-demo/
I checked and this is broken in 51, and working in 52, 53, and 54. Since 52 is scheduled to become the new release on March 7, unfortunately I don't think it's likely this will be fixed in 51. We should make sure we have coverage for this in the test suite.
Status: UNCONFIRMED → NEW
Rank: 35
Ever confirmed: true
Flags: in-testsuite?
Priority: -- → P3
Probably the same cause as bug 1337653
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1337653
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.