Copying a space followed by a line break yields two spaces

VERIFIED FIXED in M13

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: elig, Assigned: akkzilla)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [COPY/PASTE])

Attachments

(1 attachment)

Reporter

Description

20 years ago
<broken out of 12551>

* TITLE/SUMMARY
Copying a space followed by a line break yields two spaces

* STEPS TO REPRODUCE
0) Launch Apprunner
1) Using the attached test case, copy the entire "CodeStock Web Developer
Seminars" paragraph.
2) View the Clipboard

* RESULT
 - What happened

When you copy text from a web page whose source contains a word, followed by a
space, followed by a line break (not a <BR>; an actual line break), followed by a
word, two spaces appear between the words.

In this case, you'll see "web content with" (two spaces b/w 'content' & 'with'):

        The source is:

<--->
web content
with
<--->
(with a space after the word "content")

 - What was expected

One space between words.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (19990808 optimized build)
        Win32 Apprunner (19990808 optimized build [NT 4, Service Pack 3])

 - Can't Reproduce On
        Linux Apprunner (1999082316 [busted] build date; probably this morning's
build.) Copy doesn't function.


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
Reporter

Updated

20 years ago
QA Contact: sujay → elig
Reporter

Comment 1

20 years ago
[QA Assigning to self.]
Reporter

Updated

20 years ago
Blocks: 12551
Reporter

Comment 2

20 years ago
Posted file Test Case
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
Assignee

Comment 3

20 years ago
This is actually happening because the parser is calling us multiple times for
adjacent whitespace nodes.  I'm going to try to work around it in the sink
stream, but cc'ing parser people since it doesn't seem like it ought to be doing
this.
Assignee

Updated

20 years ago
Target Milestone: M15 → M12
Assignee

Comment 4

20 years ago
M12.  Copy/paste of basic plaintext is important for beta.
Assignee

Comment 5

20 years ago
Changing Component to Output.

Updated

20 years ago
Summary: Copying a space followed by a line break yields two spaces → [BETA] Copying a space followed by a line break yields two spaces
Whiteboard: [COPY/PASTE]
Target Milestone: M12 → M13

Comment 6

20 years ago
I'm moving this to M13, it's a must have for beta

Updated

20 years ago
Blocks: 19423

Updated

20 years ago
Summary: [BETA] Copying a space followed by a line break yields two spaces → Copying a space followed by a line break yields two spaces
Whiteboard: [COPY/PASTE] → [COPY/PASTE FEATURE]

Comment 7

20 years ago
updating summary fields

Updated

20 years ago
Summary: Copying a space followed by a line break yields two spaces → [FEATURE]Copying a space followed by a line break yields two spaces

Comment 8

20 years ago
Moving [FEATURE] to Summary for queries.

Updated

20 years ago
Summary: [FEATURE]Copying a space followed by a line break yields two spaces → Copying a space followed by a line break yields two spaces
Whiteboard: [COPY/PASTE FEATURE] → [COPY/PASTE]

Comment 9

20 years ago
the information in the whiteboard summary is for me to track what folks are
working on, just to keep things simple, I won't put the word feature in anymore
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 10

20 years ago
Daniel Brattell's changes should have fixed this, and have as far as I can tell.
 Marking fixed ... please reopen with a new test case if you're still seeing it.
Reporter

Updated

20 years ago
Status: RESOLVED → VERIFIED
Reporter

Comment 11

20 years ago
Verified fixed using 2000011208 Mac OS smoke-tested build, as well as the
2000011108 Win32/Linux smoke-tested builds.

Test case now functions, as did a variant checked on Mac OS of placing the the
line break before the space (and in between two spaces).

Comment 12

20 years ago
Bulk move of all "Output" component bugs to new "DOM to Test Conversion" 
component.  Output will be deleted as a component.

Updated

20 years ago
Component: Output → DOM to Text Conversion
You need to log in before you can comment on or make changes to this bug.