Closed Bug 1344220 Opened 3 years ago Closed 2 years ago

Enable stub installer downloads for win64 for all desktop Firefox channels

Categories

(www.mozilla.org :: Bedrock, enhancement)

Production
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pmac, Assigned: pmac)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

See dependent bugs.

Bouncer will now serve the 32bit windows stub installer for the "win64" platform requests. This is because the 32bit stub installer is smart enough to download the 64bit build if running on a 64bit windows machine. This bug covers updating the download links on www.m.o for win64 to stub installer.
For those watching at home, the stub installer exe itself must be a 32-bit application so it can run on both 32- and 64-bit Windows (and then decide whether to download the 32- or 64-bit Firefox package at install time).
As a reminder - for Nightly and Aurora we can only change en-US for now (see bug 1339870).
Above PR is to enable stub for win64 for all locales or release and beta, and en-US only for aurora (alpha) and nightly.
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5d34c8755fef122b38855a4ee25357262d561873
Bug 1344220: Enable stub installer for win64

All locales for beta and release, and en-US only for aurora and nightly.

https://github.com/mozilla/bedrock/commit/0ba7c406aa44213033bab82eb9968f3ce748f45e
Merge pull request #4709 from pmac/stub-installer-win64-all-channels

Bug 1344220: Enable stub installer for win64
Depends on: 1348610
The above PR has been reverted in Bug 1348610, so the change (plus code clean-up) has to be made again to merge the Firefox 32/64-bit download buttons. The current plan is still on track for Firefox 55, right?
Flags: needinfo?(cpeterson)
Duplicate of this bug: 1258224
> Stub installer for win64 is scheduled to ride the Fx 55 train,
> we should not enable it for more channels (aurora, beta, release)
> until we're told that smart switching has been enabled in the stub.

Paul, a change landed in bug 1348610 with a comment in bedrock/settings/base.py saying:

-        'win64': STUB_INSTALLER_ALL, 
+        # should come back in Fx 55
+        # bug 1348610
+        # 'win64': STUB_INSTALLER_ALL,

https://github.com/mozilla/bedrock/commit/436d87f986412fc0d23393d40b730e12fb10e138

What exactly "should come back in Fx 55"? Is the comment referring to a 64-bit binary of the stub installer itself?

The current Firefox 54 stub installer is itself a 32-bit binary, but it decides locally whether to download the 32-bit or 64-bit Firefox package. We don't have any plans to have a 64-bit binary of the stub installer itself because the 32-bit stub installer binary can run on both Win32 and Win64 OS.

If I understand the comment correctly, it is not necessary and we can just remove it.
Flags: needinfo?(cpeterson) → needinfo?(pmac)
You may be right. We certainly didn't know that the stub would handling this on its own at that point. We just have to ensure that we're showing the right bouncer URL to win64 users. It'd be best if bouncer could serve the 32bit stub if the "os" attribute is either "win" or "win64" since deciding when to show a user the 64bit button can be a bit error prone.

Our download button code is showing its age a bit. It might be nice to take stock of all of the possible downloads, make sure they're available and consistent in bouncer, and rework our buttons to match that.
Flags: needinfo?(pmac)
bouncer is set up as you'd like already. eg, here's Mihai adjusting the config the other day for a change of name in 55 on beta:
https://hg.mozilla.org/releases/mozilla-beta/diff/73a5be6013ce/testing/mozharness/configs/releases/bouncer_firefox_beta.py
Nice! Thanks :nthomas! So it seems the answer is to uncomment that setting from comment #8 when 55 lands then so that win64 buttons switch to stub instead of full installers.
(In reply to Paul [:pmac] McLanahan ET needinfo? me from comment #11)
> Nice! Thanks :nthomas! So it seems the answer is to uncomment that setting
> from comment #8 when 55 lands then so that win64 buttons switch to stub
> instead of full installers.

Which "win64 buttons" are those? Is this bug about the https://www.mozilla.org/firefox/new/ download page, the https://www.mozilla.org/firefox/all/ download page?

The /new page can safely default to the stub installer for both "win" and "win64", but we would still like both the 32-bit and 64-bit full installers to be available for download somewhere, such as the /all page. Some users with little RAM may prefer to run 32-bit Firefox even though the stub installer would default to 64-bit. In those cases, the user's only option is to download the 32-bit full installer.
Flags: needinfo?(pmac)
Buttons like the ones on

https://www.mozilla.org/en-US/firefox/channel/desktop/

They link directly to downloads. Currently the Win button for Beta points to stub and the Win64 button points to the full installer. This change would have the 64bit button also use stub. The /all pages with all full downloads will be unaffected.
Flags: needinfo?(pmac)
Okay. 55 is out and does indeed appear to have shipped with the smart stub that will do the 32/64 bit decision itself. Are we now clear to ship giving stub installer to all win users?
Assignee: nobody → pmac
Status: NEW → ASSIGNED
This PR enables stub installer for all download buttons for win and win64 any any enabled locale for all release channels. My testing of bouncer suggests this should all work fine.
Attachment #8845119 - Attachment is obsolete: true
(In reply to Paul [:pmac] McLanahan ET needinfo? me from comment #15)
> This PR enables stub installer for all download buttons for win and win64
> any any enabled locale for all release channels. My testing of bouncer
> suggests this should all work fine.

From the installer perspective, I think your proposed change looks good, as long as the full installers are still available for both 32-bit and 64-bit on the /all page (as you already confirmed they will be in comment 13). :)
Great. Thanks :cpeterson! We'll be double-checking all of that again during deployment as well. I'll get the PR reviewed and merged as quickly as possible.
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/509e000143aace91e8645a87a15b973483bec8f8
Fix bug 1344220: Enable stub installer for all locales for all windows

https://github.com/mozilla/bedrock/commit/3f61e5547c3a9e11075ef5943ed02ce98bb0c68c
Merge pull request #5041 from pmac/stub-for-all-1344220

Fix bug 1344220: Enable stub installer for all locales for all windows
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.