Sits at 100% CPU grabbing RAM and stops responding

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
critical
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: Alex Slater, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

When the URL (http://www.vertigogalleries.com/) is entered, the browser stops
responding to commands and nothing is rendered to the display at all. At the
same time the executable sits at 100% CPU and continuously allocates RAM.

The process has to be killed to carry on.

(The site displays fine in IE v5.00.3315.1000)


Reproducible: Always
Steps to Reproduce:
1. Enter http://www.vertigogalleries.com/
2. Hit enter

Actual Results:  The browser stops responding to commands and nothing is
rendered to the display at all. At the same time the executible sits at 100% CPU
and continuously allocates RAM.


Expected Results:  Displayed either the page, or an error message. Basically
anything other than hang and chew through RAM  :-)

Machine is running Win2k Pro SP2 with 640MB RAM on a P3-900Mhz.

Comment 1

17 years ago
Hmm. Probably site bug but we shouln't be freezing.

Confirming on linux trunk 2002033015 
os -> all

here's the bad code:
function preload(src)
{
    i=new Image;
    i.src=src;
}

preload_src=Array('nav_about_on.gif','nav_sales_on.gif','nav_vmp_on.gif','nav_galleries_on.gif','nav_gifts_on.gif','nav_picks_on.gif');
for(i=0;i<preload_src.length;i++) 
{
    preload('http://www.vertigogalleries.com/images/'+preload_src[i]); 
}

the code inside preload() modifies i every time causing the for loop to behave
incorrectly
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 2

17 years ago
-> evang
Assignee: asa → doronr
Component: Browser-General → US General
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified

Comment 3

17 years ago
comment submitted via feedback form on site indicating problem ...
WFM on Windows XP build 2002071108.
I peaked at the JS on http://www.vertigogalleries.com/.. doesn't seem they've
done anything about it, but perhaps this has been fixed in mozilla since this
bug was opened.

I'm not fully educated in the way we deal with evangelism bugs.. should this be
resolved WFM, or ?

Comment 5

16 years ago
WFM, reopen if you can reproduce this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.