'revision comment box' needs to be a multi-line textarea

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: jan, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

Just left an 'angry' comment in the 'the revision comment box' after having edited a documentation page - instead of writing what changes I have done - sorry for that.

You state:
"We know that the revision comment box being so far away from the save buttons doesn't make any sense. We're working on design changes that will fix that."

That is just a minor problem. The big problem is that typing a 'return' will not start another line, but somehow 'saves' the edits. And there are several "save buttons" - which one did you use? "DISCARD" - hope not?

The revision comment box must function exactly as the entry field I'm typing this very comment into. And it should be not just one line tall. This sends the user - me - the message that you aren't really interested in the comments and fear that I will 'misuse' it for long tirades - as I'm admittedly doing right now...:) Please no Twitter-like limitations either, as users shouldn't have to be precedential - pun intended:)
Component: General → General
Product: Developer Documentation → Mozilla Developer Network
The purpose of the comment box is for a short, one-line summary of the revision. It appears in a few places:

* Revision history for a document, such as https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/splice$history
* The revision dashboard: https://developer.mozilla.org/en-US/dashboards/revisions
* Various content-watching emails, where a diff of the change is also included.

Multi-line revision comments make these views less useful. Changing from "enter is form submit" to "enter is next line" could break the workflow of our current editors.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

2 years ago
(In reply to John Whitlock [:jwhitlock] from comment #1)
> The purpose of the comment box is for a short, one-line summary of the
> revision. It appears in a few places:
> 
> * Revision history for a document, such as
> https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/
> Global_Objects/Array/splice$history
> * The revision dashboard:
> https://developer.mozilla.org/en-US/dashboards/revisions
> * Various content-watching emails, where a diff of the change is also
> included.
> 
> Multi-line revision comments make these views less useful. Changing from
> "enter is form submit" to "enter is next line" could break the workflow of
> our current editors.
Really?
1) The purpose of the comment box should be a good comment, as long as the user may want to make such comment. The more specific, detailed a comment is, the better it should be for 'our current editors.'
2) You completely failed to address the 2nd part:
The big problem is that typing a 'return' will not start another line, but somehow 'saves' the edits. And there are several "save buttons" - which one did you use? "DISCARD" - hope not?
(Reporter)

Comment 4

2 years ago
yes, this issue prevented me from outlining the edits I made.
They were:
1) Changed 'arr' to 'array' to be consistent with the top 'declaration'.
2) Added 1/2 sentence clarifying that missing 3rd parameter really means (after 'i.e.')
3) Added the last code example that shows the effect.
I've updated the comment for the revision.  The newlines appear in the page source, but not in the displayed HTML - we'd have to encode them as line breaks.

https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/splice$compare?from=1213911&to=1214067
You need to log in before you can comment on or make changes to this bug.