Closed Bug 1344661 Opened 3 years ago Closed 3 years ago

Capture input sample for CheckForSPSChange()

Categories

(Core :: Audio/Video: Playback, defect)

Other Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: alwu, Assigned: alwu)

Details

Attachments

(1 file)

When the SPS changed, we save the input sample in |mPendingSample|, and then call CreateDecoderAndInit(mPendingSample) after calling shutdown(). 

However, the |mPendingSample| has been clear in shutdown(), so actually we send the nullptr to CreateDecoderAndInit().
Comment on attachment 8843903 [details]
Bug 1344661 - capture input sample for CheckForSPSChange().

https://reviewboard.mozilla.org/r/117526/#review119166
Attachment #8843903 - Flags: review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/741f09f1b7f0
capture input sample for CheckForSPSChange(). r=jya
https://hg.mozilla.org/mozilla-central/rev/741f09f1b7f0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8843903 [details]
Bug 1344661 - capture input sample for CheckForSPSChange().

Approval Request Comment
[Feature/Bug causing the regression]: Fix the potential crash
[User impact if declined]: Got crash if the video changed its SPS content during playing
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: Doesn't change any logic, just store the pending input which would be reset incorrectly
[String changes made/needed]: No
Attachment #8843903 - Flags: approval-mozilla-aurora?
Gerry, 
Could you help on comment 6?
Bug 1344649 comment 41 is also waiting for this.
Flags: needinfo?(gchang)
Comment on attachment 8843903 [details]
Bug 1344661 - capture input sample for CheckForSPSChange().

Approval Request Comment
[Feature/Bug causing the regression]: Caused by bug 1336431. Browser would crash if the video changes its SPS during playing.
[User impact if declined]: Got crash if the video changed its SPS content during playing
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: Doesn't change any logic, just store the pending input which would be reset incorrectly
[String changes made/needed]: No
Comment on attachment 8843903 [details]
Bug 1344661 - capture input sample for CheckForSPSChange().

Fix a potential crash. Aurora54+.
Flags: needinfo?(gchang)
Attachment #8843903 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.