Closed Bug 1344690 Opened 3 years ago Closed 3 years ago

'Environment key "mozilla/simpletest" is unknown' when running eslint on some mochitests

Categories

(Firefox Build System :: Lint and Formatting, defect)

3 Branch
defect
Not set

Tracking

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 fixed, firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Running mochitest, we're seeing:

$ ./mach eslint browser/base/content/test/general/browser_private_browsing_window.js
An error occurred running eslint. Please check the following error messages:

/Users/mark/dev/gecko/testing/mochitest/mochitest.eslintrc.js:
	Environment key "mozilla/simpletest" is unknown

Referenced from: /Users/mark/dev/gecko/browser/base/content/test/general/.eslintrc.js
Error: /Users/mark/dev/gecko/testing/mochitest/mochitest.eslintrc.js:
	Environment key "mozilla/simpletest" is unknown


This is a regression from bug 1343519.

The issue is that every *eslintrc.js that uses a "mozilla/..." environment, must also list the "mozilla" plugin in that same file (listing it in the top-level is not enough).

See https://github.com/eslint/eslint/issues/6030 for more info.
And, although I'd seen it previously, I had obviously missed adding the plugin section to mochitest.eslintrc.js.
Comment on attachment 8843935 [details]
Bug 1344690 - Fix an issue with 'Environment key "mozilla/simpletest" is unknown' when running eslint on some mochitests.

https://reviewboard.mozilla.org/r/117542/#review119232
Attachment #8843935 - Flags: review?(jaws) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6bf15db3f159
Fix an issue with 'Environment key "mozilla/simpletest" is unknown' when running eslint on some mochitests. r=jaws
https://hg.mozilla.org/mozilla-central/rev/6bf15db3f159
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Whiteboard: [checkin-needed-aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/450acaa80eaa
Flags: in-testsuite+
Whiteboard: [checkin-needed-aurora]
Product: Testing → Firefox Build System
Keywords: regression
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.