DatePicker <input type="date"> does not allow to directly change year

RESOLVED DUPLICATE of bug 1318046

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED DUPLICATE of bug 1318046
9 months ago
9 months ago

People

(Reporter: Jan Thiel, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

Open a website using HTML5 native date input <input type="date">. Like here: https://jsfiddle.net/z61Lsvh4/

Click into the date field and try to select your birthday (or a date ~20 years in the past) with the Firefox Mobile Datepicker.


Actual results:

I would expect to change the year in the datepicker directly to select my birthdate for example. As this is not possible I have to go back in time month by month which is the only navigation paragigma for the datepicker.


Expected results:

You should be able to tab the year and directly change it in some way like on any other native smartphones datepicker implementation. 

If there is any other way to quickly navigate years in the picker, please let me know. We have many customers on Firefox mobile complaining about "our" website and implementation where they have to select their birthday. On mobile we use native elements whenever useful. For date this was true until we got aware of this Firefox Mobile issue aka usability hell.
Hello and thank you for the report!

There is a bug filed for this issue so please follow that one. Thanks again!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318046
You need to log in before you can comment on or make changes to this bug.